Hifonics Brutus Bxi 2006D in protect - Page 6 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd November 2012, 12:47 AM   #51
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If the amp was producing rail voltage, the trace should deflect either up or down when you touch the probe to it.

Does the trace deflect up and remain up when you touch the scope probe to the positive terminal of your 12v power supply?
  Reply With Quote
Old 3rd November 2012, 01:31 AM   #52
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
the trace deflects up and stays up when connected to 12v power supply
  Reply With Quote
Old 3rd November 2012, 01:52 AM   #53
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a photo of the center leg of the power supply FETs. Set the scope to 10us and 10v/div.
  Reply With Quote
Old 3rd November 2012, 02:27 AM   #54
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
the probe of meter slipped and shorted an output fet while checking i need to check those and figure out why its blowing my 10a fuse in my power supply, anny suggestions? ive removed and tested the output fets so far they are good but drain and source legs (2 and 3) read shorted and solder pads read shorted with fets removed... 4 fets on one side tested bad after further analysis after i get the replacements in a few days ill check the power supply fets

Last edited by bigpun4fubu; 3rd November 2012 at 02:38 AM.
  Reply With Quote
Old 3rd November 2012, 03:47 AM   #55
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Check D202 near the drivers for the audio outputs.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help! Hifonics Brutus bxi 2010D 2000 Watt Amp! ZarazuaT Car Audio 12 15th January 2013 09:09 PM
hifonics bxi 2000 brutus timwebb Car Audio 3 7th May 2012 05:06 AM
Hifonics Brutus BXI 2008D mike49504 Car Audio 13 17th February 2012 05:21 AM
Hifonics Brutus BXi 2608D Dr Zeus Car Audio 6 16th June 2011 04:34 AM
Hifonics Brutus BXi 1606d parts Bertje Car Audio 2 3rd June 2010 04:33 PM


New To Site? Need Help?

All times are GMT. The time now is 01:26 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2