Hifonics Brutus Bxi 2006D in protect - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th August 2012, 08:15 PM   #11
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
That transistor is in parallel with other (adjacent) transistors. I'd suspect broken traces or pulled vias if it reads shorted and the others do not.
  Reply With Quote
Old 30th August 2012, 08:17 PM   #12
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
vias?
  Reply With Quote
Old 30th August 2012, 08:24 PM   #13
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
the 3 in that bank read 0 ohms across legs 2 and 3
  Reply With Quote
Old 31st August 2012, 01:57 AM   #14
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Vias are the copper feed-throughs that connect the traces on one side of the board to the traces on the other side of the board.

Are either of the other two shorted? If not, there may be an open connection between the drive circuit and the gate of the FET that was preventing the FETs from switching off.
  Reply With Quote
Old 31st August 2012, 08:58 AM   #15
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
all 3 read shorted in circuit
  Reply With Quote
Old 1st September 2012, 10:06 AM   #16
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are all 3 OK out of the circuit?

Did you check the ones on the other side?

Many times, when you have parallel transistors, you can find the shorted one by measuring the resistance from the gate to the drain. The shorted one will read lower resistance than the other ones.
  Reply With Quote
Old 2nd September 2012, 05:38 AM   #17
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
the other side checks fine , here is Q203 of the bank what it reads out of circuit, will post other 2 as well

Click the image to open in full size.

Last edited by bigpun4fubu; 2nd September 2012 at 05:49 AM.
  Reply With Quote
Old 2nd September 2012, 05:49 AM   #18
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
Q204

Click the image to open in full size.
  Reply With Quote
Old 2nd September 2012, 05:51 AM   #19
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
These are OK. If the 3rd one is similar, it's also OK.
  Reply With Quote
Old 2nd September 2012, 06:01 AM   #20
diyAudio Member
 
Join Date: Oct 2010
Location: Florence, Alabama
Q202

Click the image to open in full size.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help! Hifonics Brutus bxi 2010D 2000 Watt Amp! ZarazuaT Car Audio 12 15th January 2013 08:09 PM
hifonics bxi 2000 brutus timwebb Car Audio 3 7th May 2012 04:06 AM
Hifonics Brutus BXI 2008D mike49504 Car Audio 13 17th February 2012 04:21 AM
Hifonics Brutus BXi 2608D Dr Zeus Car Audio 6 16th June 2011 03:34 AM
Hifonics Brutus BXi 1606d parts Bertje Car Audio 2 3rd June 2010 03:33 PM


New To Site? Need Help?

All times are GMT. The time now is 03:34 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2