diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   autotek mm2000.1d no output (http://www.diyaudio.com/forums/car-audio/218236-autotek-mm2000-1d-no-output.html)

gettinthechewin 20th August 2012 08:27 AM

autotek mm2000.1d no output
 
i have a autotek mean machine 2000.1d that i am repairing. it turns on and does not go into protect mode. but it has no output on the speaker terminals. i have put this amp into 2 cars with working systems, i have pulled out the amp and replaced with the 2000.1d , so all wires are good to amp and still no output. i have removed board from amp heatsink and do not see any signs of burned components or traces on circuit board, accept a trace that looks to have been repaired at some point on the lil circuit board that is connected to the main board. i think that its the driver board. but idk. any ideas of what components i should check to try to find the problem with the output. i have a dmm and a bench power supply and a toolbox with the regular stuff in it nothing fancy and no scope.. just wondering if any1 has any ideas of what i should check to begin trouble shooting this amplifier. i can post pics of any/all parts areas of board if need

timwebb 20th August 2012 03:33 PM

Is this a older one?

brandes.cm 22nd August 2012 05:19 AM

Does the relay turn on? You should hear a audible click.

gettinthechewin 22nd August 2012 07:38 AM

i am not sure if this is an older model 2000.1d or newer. it appears to be a newer amp,( its owned by maxsonnics) .it is exactly the same as the amp pictured but not amp in pic link Autotek MM2000.1D - Car Audio Classifieds . i could be mistaken but appears to be two relays. when it powers up i get power light ,does not go into protect , i can hear a relay when it turns on but get no sound out of amp

Perry Babin 22nd August 2012 08:35 AM

Do you have supply voltage on the power supply pins of the op-amps?

Do you have both positive and negative rail voltage on the output transistors?

gettinthechewin 22nd August 2012 08:40 AM

i will check that and let u know what i have.thanks


All times are GMT. The time now is 03:13 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2