Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Infinity 7541a problems please help
Infinity 7541a problems please help
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd August 2012, 04:10 AM   #1
Darkwing12095 is offline Darkwing12095
diyAudio Member
 
Join Date: Aug 2012
Default Infinity 7541a problems please help

Alright guys here's my issue. I installed the amp and have everything run correctly. I turn on my car and the amps protect light comes on and then fades out after about five seconds and nothing else happens. I am getting 12.5 amps to the amp and the ground is valid. The fuses are also fine. What could potentially be wrong???

Bruce
  Reply With Quote
Old 3rd August 2012, 07:11 AM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You need to measure the DC voltage directly across the screw terminals on the amp. Monitor the voltage from just before remote voltage is applied and the time that the protect LED is illuminated. Does the voltage ever drop to below 12v?

The output transistors could be shorted but you need to confirm that you have good power connections (as described above) before you do anything else.
  Reply With Quote
Old 7th August 2012, 12:36 AM   #3
ArcticBreaze is offline ArcticBreaze  New Zealand
diyAudio Member
 
ArcticBreaze's Avatar
 
Join Date: Dec 2010
Location: Oamaru
also check the impedance of your speakers, alot of car amps don't like anything below 4 ohms. especiallly if you have the outputs bridged. how are your speakers conected and how many. If voltage is good and speaker impeadance is also good you have a faulty amp.
__________________
Fat Tubes For Fat Sounds
  Reply With Quote

Reply


Infinity 7541a problems please helpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
infinity referance 7541A amp popping alti117 Car Audio 2 26th January 2014 04:28 PM
Infinity 7541a Distorted high frequency / noise in all channel hyoo Car Audio 17 8th April 2012 06:01 AM
Need help troubleshooting Infinity 7541a jaimegmr Car Audio 50 14th November 2010 09:07 AM
Infinity BU1 amplified subwoofer. problems. pat allen Solid State 0 30th December 2004 02:42 PM


New To Site? Need Help?

All times are GMT. The time now is 04:42 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki