Kenwood KAC-X811D, Low power output - Page 3 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd August 2012, 01:33 AM   #21
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I can't see how the amp is defective if it drive 35v AC into the speaker. That should be driving the speaker pretty well.
  Reply With Quote
Old 2nd August 2012, 12:33 PM   #22
diyAudio Member
 
Join Date: Jul 2012
Hummm interesting... Thanks for your help... I will do some further testing, and let you know my findings.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood Kac-819 won't power up! thejulianath20 Car Audio 30 12th July 2011 09:55 PM
KAC-9152D Kenwood - No Power kmil Class D 15 21st December 2010 03:07 PM
Kenwood KAC-X811D Current issues shawnschuldt Car Audio 5 23rd September 2008 03:17 PM
Kenwood KAC-8152D no power tritron Car Audio 2 14th May 2008 06:52 AM
Kenwood KAC-X301T and KAC-X201T:Do they share the same board? spooney Car Audio 1 25th October 2007 02:08 AM


New To Site? Need Help?

All times are GMT. The time now is 04:50 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2