diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   MTX Thunder 275X (http://www.diyaudio.com/forums/car-audio/215928-mtx-thunder-275x.html)

Adam248 10th July 2012 05:16 PM

MTX Thunder 275X
 
I've got a problem blowing fuses as soon as i add power.There is no signs of bad components or damage. Dose anyone know what it might be?

Perry Babin 10th July 2012 10:52 PM

Does the fuse blow with no remote voltage applied?

Adam248 11th July 2012 01:12 AM

no,with the lead+ connected and as soon as i connect the ground- it pops the fuse...no remote wire yet :(

Perry Babin 11th July 2012 02:51 AM

What tests have you performed to determine that there are no defective components?

Adam248 22nd July 2012 01:42 PM

i have checked the fets via diode tester to find one ir540 has shorted and seems to me a P60ne 06-16 power fet is shorted too .I have ordered a few ir540s ,have yet to order the p60ne 06-16 power fet .All diodes check good too ,should i replace all the fets together or just the ones ?

Perry Babin 23rd July 2012 12:04 AM

You should replace all of the FETs in the channel with the shorted FET. If the power supply FET has failed, you need to replace all of the power supply FETs.


All times are GMT. The time now is 01:58 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2