Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th June 2012, 12:18 AM   #1
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Default Hifonics HFI2000D goes to protect

Amp goes directly into protect, I noticed pin 1 of TL494 reads 5.86V and pin 2 reads 2.56V. I believe this ties to +rail and uses a divider to set the voltage.

I have pulled the output driver card and measured the transistors, all read OK.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 18th June 2012, 11:29 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If no one else can help, post a photo of the board.
  Reply With Quote
Old 18th June 2012, 12:08 PM   #3
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Photo coming later, but this amp is no different than the later Brutus stuff.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 18th June 2012, 09:30 PM   #4
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Click the image to open in full size.

Click the image to open in full size.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 18th June 2012, 11:38 PM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Pin 1 can't be driven high by the positive rail if the IC isn't producing output. Are you sure that it's not being driven high by the comparator/op-amp?
  Reply With Quote
Old 19th June 2012, 12:13 AM   #6
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
I find no other connection to that pin and now wonder if the TL494 is just bad. Attached is a schematic for a BX1500D, seems close.
Attached Files
File Type: pdf BX1500D-F.pdf (56.1 KB, 59 views)
File Type: pdf BX1500D-M.pdf (98.4 KB, 55 views)
File Type: pdf BX1500D-P.pdf (71.7 KB, 53 views)
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 19th June 2012, 12:29 AM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If the circuit is the same and the 4.7k resistor is within tolerance, the IC is defective.

Something that doesn't seem right is the 2.5v on pin 2. Pin 2 should be at 5v according to the diagram. If it's at 2.5, that would seem to indicate that there is a voltage divider that's not shown in the diagram.
  Reply With Quote
Old 19th June 2012, 12:32 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is it possible that pins 1 and 7 of the comparator go to diodes D9 and D10 and then to pin 1 of the 494?
  Reply With Quote
Old 19th June 2012, 12:57 AM   #9
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
I lifted pin 1 and it goes to 14.4V when measuring on the pin. I assume the IC doesn't have a pull-up resistor built in.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 20th June 2012, 01:37 AM   #10
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Quote:
Originally Posted by Perry Babin View Post
Is it possible that pins 1 and 7 of the comparator go to diodes D9 and D10 and then to pin 1 of the 494?
Yes that is correct.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics Zeus VIII stuck in protect mbates14 Car Audio 11 16th May 2012 01:36 AM
Hifonics BXi2006d not coming out of protect. Any advice? RRR37 Class D 7 6th July 2011 03:35 AM
amp goes to protect, why? eeyore757 Subwoofers 6 21st March 2007 11:29 PM


New To Site? Need Help?

All times are GMT. The time now is 05:11 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2