Jl Audio G1700 4 cap blow - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th June 2012, 07:00 AM   #1
diyAudio Member
 
Join Date: Jun 2012
Location: Texas
Default Jl Audio G1700 4 cap blow

Hi, I have this amp jl audio, I buy from a friend, the amplifier showed no signs of life, then proceeded to open it and found burned four capacitors of 2200uf 25v 105degress and a track to open the transformer all the componets look good and the diode trans is good.

Click the image to open in full size. I then proceeded to repair the 2200uF 50V capacitor components 4 105 degrees and weld the track making this the amp on but as you want to protecion mode but nothing more, no audio and power leds and protecion, flash


this is the pic of the complete amp

Click the image to open in full size.
  Reply With Quote
Old 12th June 2012, 10:59 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are the legs on any of the heatsink mounted components broken? You may have to twist them slightly to see the break if they are broken.

What are you using for a power supply?

Do you have a scope?
  Reply With Quote
Old 12th June 2012, 01:59 PM   #3
diyAudio Member
 
Join Date: Jun 2012
Location: Texas
not, not legs broken i put out the board and nothing,i'm using a 12 v battery of my children power wheel and i only use a multimeter not scope on my hands.

Last edited by kalacho2006; 12th June 2012 at 02:02 PM.
  Reply With Quote
Old 12th June 2012, 09:40 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
JL audio amplifiers are very sensitive to voltage. If the amp is causing an instantaneous voltage drop (not visible by using a multimeter), it could be causing the amp to go into protect.
  Reply With Quote
Old 13th June 2012, 01:00 AM   #5
diyAudio Member
 
Join Date: Jun 2012
Location: Texas
The 4 new caps can cause the drop voltages?
Because when I replace 2 of they are nichicon and 2 unknow brand (kmc) and double of voltage 50v.
  Reply With Quote
Old 13th June 2012, 03:22 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If the 12v supply (battery in this instance) has too much internal resistance or insufficient capacity, the 12v will drop. This has nothing to do with the capacitors in the amp.
  Reply With Quote
Old 20th June 2012, 11:00 PM   #7
diyAudio Member
 
Join Date: Jun 2012
Location: Texas
ok, I use a car battery to check again the amplifier and same problem, amp turn on but the protection led flash,cheking the board i noticed 4 leds on the board not power on and others yes, maybe the circuit not power on is fail, i noticed too 2 op amp JRC 2082 and 2068 on the yellow strip under the pot are heat at touch, all the board are cool only this 2 components are heat. some ideas where start ?
Click the image to open in full size.
  Reply With Quote
Old 21st June 2012, 12:29 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Measure the DC voltage with the black probe on pin 4 and the red probe on pin 8. Post the voltage on both ICs.
  Reply With Quote
Old 27th June 2012, 07:59 PM   #9
diyAudio Member
 
Join Date: Jun 2012
Location: Texas
Hey perry how much for repair this amp for me? I can send to you and pay shipping costs.
  Reply With Quote
Old 27th June 2012, 08:01 PM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I'm not taking anything in at this time. I won't likely catch up until August.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jl audio 500/1 powers on with low audio out help needed ivkata Car Audio 29 19th August 2011 12:21 AM
Can I run a 10 inch JL audio and a 12 inch JL audio off same amp ash4kel Car Audio 2 8th April 2011 02:12 AM
JL Audio 10w6v2 or Infinity Kappa 100.3se? Audison SRX4 or Jl 300/4? DcMaN Subwoofers 1 17th September 2010 10:28 AM
NAD fuses, slow blow or fast blow? AllCaster Solid State 3 25th October 2009 06:11 PM
Just had a power cap blow! azira Parts 19 24th June 2004 09:28 AM


New To Site? Need Help?

All times are GMT. The time now is 07:44 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2