Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th June 2012, 09:30 AM   #11
azvrt is offline azvrt  Netherlands
diyAudio Member
 
Join Date: Dec 2010
Location: Netherlands
Do you have the schematics for this amp ? I don't have 500sx but do have 500s and they are probably 99% identical.

The fact that your amp is always in high current mode must be looked at. I hope you can solve the issue.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundstream Reference 500sx Repair sdiesel Car Audio 18 16th April 2014 12:17 AM
soundstream reference feb board replacement russdeanlee Car Audio 8 16th March 2012 11:46 AM
Sound stream reference Picasso (blue board) problem russdeanlee Car Audio 0 10th March 2012 10:25 AM
Soundstream Reference 500sx problem azvrt Car Audio 13 11th February 2012 08:41 AM
soundstream reference 500sx mike49504 Car Audio 18 2nd January 2010 08:00 AM


New To Site? Need Help?

All times are GMT. The time now is 06:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2