orion cobalt 800 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th May 2012, 08:06 AM   #1
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
Default orion cobalt 800

im repairing this amp.so i got it to play and at about half volume the speaker sucks in and out like there is dc coming out.could it be a preamp issue?
  Reply With Quote
Old 26th May 2012, 03:32 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Some amps will oscillate if there is an open shield ground.
  Reply With Quote
Old 26th May 2012, 09:53 PM   #3
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
there was really bad solder joints at the rca jacks so i resolderd it. could i ground the rca shield and see if it goes away?
  Reply With Quote
Old 26th May 2012, 10:26 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Of you don't read 0 ohms between the RCA shield and the secondary ground, you could try connecting a jumper between those two points.
  Reply With Quote
Old 27th May 2012, 01:28 AM   #5
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
i read 0 ohms between the secondary ground and the rca shield.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Orion Cobalt 300.2 mike49504 Car Audio 1 18th March 2012 10:50 PM
Help with Theta 307 Cobalt / Voltage Scabiko Digital Line Level 0 10th March 2012 02:37 AM
Orion Cobalt 304, 1 channel not working ash4kel Car Audio 10 29th March 2011 10:44 PM
orion extreme 800 amp 2potter Car Audio 4 7th March 2011 09:39 PM
orion 800.2 amp ampjunkielikeme Car Audio 7 13th April 2009 04:13 AM


New To Site? Need Help?

All times are GMT. The time now is 01:58 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2