Hifonics Brutus BRZ1200.1D - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th May 2012, 02:35 AM   #1
diyAudio Member
 
Join Date: Jun 2010
Default Hifonics Brutus BRZ1200.1D

hi all

This amp came in with two shorted outputs,all PS FET and they drivers bad.I replace all the bad parts and run the amp for 20 minutes with a 500w sub.The big red coil in the output section is geting to hot to touch after 20 min is that normal for this amp?
Attached Images
File Type: jpg IMG00663.JPG (354.4 KB, 83 views)
File Type: jpg IMG00664.JPG (429.5 KB, 76 views)
  Reply With Quote
Old 25th May 2012, 01:06 PM   #2
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
i think thats normal for an inductor after 20 minutes.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hifonics hifi1000.1d ian33 Car Audio 29 13th April 2012 04:37 AM
brutus brz1200 timwebb Car Audio 3 19th June 2011 05:02 AM
Hifonics brutus bx1500d mike49504 Car Audio 33 17th April 2011 11:46 PM
Hifonics Brutus lee1976 Car Audio 3 20th July 2010 12:19 PM
hifonics brutus bxi1206d ray9043 Car Audio 2 30th March 2008 06:36 AM


New To Site? Need Help?

All times are GMT. The time now is 04:50 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2