Rockford Fosgate BD1000 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th May 2012, 06:20 AM   #1
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Default Rockford Fosgate BD1000

Hello everyone.

Recieved this amp and it wouldnt power on just blow the fuse.

I replaced 6 of the output fets that were shorted.

With no input connected the amp powers up fine and idles fine.

The drive circuit for the power supply looks good on the scope and the gate signal on the outputs fets looks good as well.

There is -13.95 on the speaker output terminal.

When a signal from the head unit is applied the amp lets out a very loud buzzing noise.

I am suspecting maybe U17

U17 reads as follows:

Pin1: -0.018
Pin2: -0.005
Pin3: -13.86
Pin4: -23.55
Pin5: -0.003
Pin6: -13.86
Pin7: -4.10
Pin8: - 0.003

Why the -23.55 on pin 4?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 24th May 2012, 11:16 AM   #2
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
You must have bad/leaky outputs with dc out there. Is the amp in protect? If not check U21.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 24th May 2012, 12:45 PM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
All of the voltages are shifted down by 13.86v. Are you sure that you didn't have the black probe on the B+ terminal?
  Reply With Quote
Old 24th May 2012, 08:10 PM   #4
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Yes I did have the probe on the B+ terminal.

There is no voltage on the output terminal.

Since the amp powers up and idles fine and does not go into protect I am going to have to assume that the problem is in the input stage.

As soon as you hook up a signal the amp starts buzzing like crazy.

Why the -23.55 volts on pin 4 of U17?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 24th May 2012, 09:20 PM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
With the black probe on the amp's ground terminal, do you still read -23 on pin 4?
  Reply With Quote
Old 25th May 2012, 12:54 AM   #6
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
No.

Pin4: -9.75 vdc
Pin7: 9.75 vdc

The rest of the pins have minimal voltage on them.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 25th May 2012, 01:08 AM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
This is normal.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate BD1000.1 jandar Car Audio 11 21st June 2013 11:43 PM
Rockford FOsgate BD1000 seankane Car Audio 30 2nd January 2012 03:48 AM
Rockford Fosgate BD1000 seankane Car Audio 133 1st April 2011 06:57 AM
rockford fosgate BD1000 mike49504 Car Audio 73 10th February 2011 06:05 PM
Rockford Fosgate BD1000 mike49504 Car Audio 1 9th January 2011 11:37 AM


New To Site? Need Help?

All times are GMT. The time now is 05:25 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2