diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   Kicker KX1200.1 - U508 and U509 (http://www.diyaudio.com/forums/car-audio/211800-kicker-kx1200-1-u508-u509.html)

nonprof 29th April 2012 11:22 PM

Kicker KX1200.1 - U508 and U509
 
thanks for having this forum...it really great helps for a newbie like me and for those people who has a very limited access sourcing a parts and resources.


I dont have schematics of KX1200.1, the problem is the IRF9640 and 640 heats and protect. I suspected the problem is the U508 or U509 but I intent to replace them all because this will give extra cost when buying from other countries. Any ideas why all these MOSFET heat up? I read a +-19V at the gate and the rail voltages decreases to just +-19V.

May I know what is the part number of U508 and U509? what is these ICs? Please...

thanks I got the U508 it LM361.


Thank you so much!

nonprof 30th April 2012 12:05 AM

Quote:

Originally Posted by nonprof (Post 3005904)
thanks for having this forum...it really great helps for a newbie like me and for those people who has a very limited access sourcing a parts and resources.


I dont have schematics of KX1200.1, the problem is the IRF9640 and 640 heats and protect. I suspected the problem is the U508 or U509 but I intent to replace them all because this will give extra cost when buying from other countries. Any ideas why all these MOSFET heat up? I read a +-19V at the gate and the rail voltages decreases to just +-19V.

May I know what is the part number of U508 and U509? what is these ICs? Please...



Thank you so much!

thanks! I used the search engine. I got the U508 it is LM361. how about U509?

Perry Babin 30th April 2012 05:10 AM

MC14060BD should be the right part number.

nonprof 30th April 2012 05:23 AM

Quote:

Originally Posted by Perry Babin (Post 3006100)
MC14060BD should be the right part number.


Thanks Again Perry!

nonprof 1st May 2012 12:40 AM

Kicker KX1200.1 - no sound
 
Hi! I replaced the LM361 U509 and followed the jumper wire stated from other post and it works fine! Protect is gone and power backs on.

But now the problem is it didn't accept any audio. It looks like muted. Do you have ideas how to fix this problem? thanks in advance!!!

nonprof 1st May 2012 04:44 AM

Quote:

Originally Posted by nonprof (Post 3007078)

Hi! I replaced the LM361 U508 and I think it's right.

Before I followed the jumper wire (C554 and R559) stated from other post the amps turns on and off to protect mode. Joining both terminals the protect mode is gone and the power backs on but new problem arises, NO sound from the output.

Thre pre-amp board looks good, I can measure output on preamp but the speaker still muted. Any ideas how to fix this problem?

I have +-12V supply to pre amp board, -11V on V.C and 0 volt on output.

I peel off land pad on pin 5, 7 and 9 of U508, Is there any active connection to these land pad?

I have a good contact from the speaker relay.

thanks in advance!!! more power to this forum...


Perry Babin 1st May 2012 06:48 AM

Post the DC voltage on all pins of the LM361.

Pin 1:
Pin 2:
Pin 3:
Pin 4:
Pin 5:
Pin 6:
Pin 7:
Pin 8:
Pin 9:
Pin 10:
Pin 11:
Pin 12:
Pin 13:
Pin 14:

nonprof 2nd May 2012 12:55 AM

Quote:

Originally Posted by Perry Babin (Post 3007250)
Post the DC voltage on all pins of the LM361.

Pin 1: 11.9
Pin 2: 0
Pin 3: 0
Pin 4: 0
Pin 5: 0
Pin 6: -12
Pin 7: 0
Pin 8: 2.9
Pin 9: 0
Pin 10: -1.8
Pin 11: 0
Pin 12: 0
Pin 13: 2.9
Pin 14: 2.9

Hi Perry, here are the voltages. thanks again!

Perry Babin 2nd May 2012 01:06 AM

Was this a new IC or one pulled from another amp?

nonprof 2nd May 2012 01:15 AM

Quote:

Originally Posted by Perry Babin (Post 3008409)
Was this a new IC or one pulled from another amp?


I pulled this from preamp board of another amp.


Thanks.


All times are GMT. The time now is 09:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2