Testing amp for clean power - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th April 2012, 12:00 PM   #1
diyAudio Member
 
Join Date: Mar 2012
Location: PVR Mexico
Default Testing amp for clean power

Hi all.i have a simple question regarding car amplifiers.i have an small car amp,a planet audio model vx2002.its 2 channel rated at 100 rms.that does not matter.i have been running this amp like 2 years without problems until two weeks.i installed a new set of four cheap speakers , soundstream ,and wired them to the amp in sets of two in paralel , giving the amplifier a minimun impedance of 2 ohms per channel, which is capable to do.i set the gains with a test tone, no problem.two days later, the tweeters of every if the four speakers got blown when i was playing them hardly.ok maybe i didnt hear distortion but well.i removed the four speakers and installed another old set,4 ford original 5x7 drivers eight ohms each.wired in the same way like the other ones,and worked very well.i re set the gains and sounded good. One day i was playing some music and one set of the speakers started to soujd very bad.removed speakers ,only to find that one of the coils in a speakers virtually got melted. Long short story, yesterday the last of the speakers got blown in the same fashion than the others. I think there is a problem with the Amp itself,because i powered that speakers before with more powerful amps (a sony444,a crossfire vr 404,a kicker 500.2) and never got a problem like this in 6 years i had these speakers working.somebody told me that my amp maybe is putting dc current in its oupots. I have tested both outs with the dmm and at full blast the most dc voltage its.25 volts.how i can test.the amp still works fine. Thanks in advance.
  Reply With Quote
Old 29th April 2012, 01:15 PM   #2
AndrewT is online now AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Could it be possible that the output only goes damagingly wrong when the amplifier gets very hot?

run the amp gently and then test the DC with the signal muted.
Run it progressively harder, checking the DC at each stage.
__________________
regards Andrew T.
  Reply With Quote
Old 29th April 2012, 07:16 PM   #3
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
I would measure the DC voltage present on the speaker terminals of the amp with no RCAs attached and no speakers attached < DC Offset > Blown and melted voice coils are likely signs of excessive DC offset and or just plain hard clipping of the amp. The DC test rules out weak or bad channels in most cases.
  Reply With Quote
Old 29th April 2012, 09:27 PM   #4
diyAudio Member
 
Join Date: Mar 2012
Location: PVR Mexico
Thanks in advance for your valuable help!

Im going to try to do both test.Actually, the amp gets enough hot after 30 minutes playing normally at 2 ohms per channel. I know it is a high load for the amp, but many times i dont play music very loudly but still the same behavior. I am going to test for dc current when the amp gets really hot.

And surely i am going to test for dc current with no rca´s attached. I did with music and most of the time i got .05 volts. If i turn to the max the gain (which i dont, because the preouts of my head unit are 3.3 volts) the higher voltage i got was .23 volts. If it can helps, i got 32 volts AC with the gain at max.

Just in case, the amp works and plays very cleanly, no strange noises, nothing. Some time ago i got some issues for overheating (i used with the same amp, bridged, two kicker comp 12 inches 8 ohms wired in parallel, getting at the end 4 ohms mono, which the manual says its ok) and after some time the amp got protected. I decided that the task for subs it was not for this amp and installed an Usamps Xt2000d, which does the work enough good.

I will post the results after testing at home. Keep the ideas coming.

Thanks again ,sorry for my spelling, still learning english.
  Reply With Quote
Old 30th April 2012, 08:31 AM   #5
AndrewT is online now AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
No, no, no.

The DC output offset test is done with the input connected to a zero ohms source impedance. AND with the speaker not connected.

When it is at the temperature you want to test at:
Turn the volume pot down to zero.
Pull out at least one speaker cable.
Read off the DC voltage across the output terminals.
__________________
regards Andrew T.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Really clean medium power amp wanted tvrgeek Solid State 7 30th December 2011 10:45 PM
Need to clean up power... moriendi Power Supplies 8 8th June 2010 11:12 PM
Testing a power amp AndrewT Solid State 8 13th August 2005 03:43 PM
How clean does power need to be? mgmopar Analogue Source 18 3rd June 2005 08:29 PM


New To Site? Need Help?

All times are GMT. The time now is 01:33 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2