Kicker SX900.4 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd April 2012, 02:02 AM   #1
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Default Kicker SX900.4

Channel 4 is out, the drive signal looks fine at Q431 and Q441. When checking the signal at Q442 and Q432 the signal loses the top half of the signal on one and the lower half on the other one.

Looking at a schematic for the IX402 seems close, but doesn't have the redundant drivers for each output device.

help is appreciated.
Attached Images
File Type: jpg 2012-04-21_20-51-25_845.jpg (588.0 KB, 29 views)
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 22nd April 2012, 02:10 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are the circuit board designations the same as the IX?

If not, you would need to list the designations for the corresponding parts.

Were the outputs in the board when you checked the drive signal?
  Reply With Quote
Old 22nd April 2012, 02:30 AM   #3
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Q431 and Q441 are Q150 and Q151 on the IX schematic
Q442,Q432 are Q160 and Q161 on the IX schematic

No outputs were populated, I had them in and it seem to produce a clean sine wave and then the outputs failed after a few minutes.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 22nd April 2012, 02:56 AM   #4
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Placed 2 outputs and the signal looks fine. Maybe the first time I didn't have the clamps tight and the fets got hot and failed.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 22nd April 2012, 09:09 AM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You can't check the drive signals in class A/AB/B amps that use negative feedback (most all commercially available amps) without the outputs in the circuit.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicker KX2500.1 brandes.cm Car Audio 10 5th February 2012 11:36 PM
Kicker DX350 Dr Zeus Car Audio 9 17th January 2011 11:13 PM
kicker kx450.2 timwebb Car Audio 21 1st July 2010 03:52 AM
Kicker SX650.1 help shagone Car Audio 12 19th March 2008 07:35 AM
Kicker Amps skooter Car Audio 3 8th November 2007 03:53 AM


New To Site? Need Help?

All times are GMT. The time now is 01:29 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2