diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   autotek mm2000.1d (http://www.diyaudio.com/forums/car-audio/211142-autotek-mm2000-1d.html)

timwebb 20th April 2012 03:07 AM

autotek mm2000.1d
 
im repairing this amp everything checks out good.the only this is the relays arent turning on.

brandes.cm 20th April 2012 03:57 AM

There is a transistor SOT-23 pkg on the P.S. driver card that turns on the relay.

timwebb 21st April 2012 12:24 AM

1 Attachment(s)
the transistors on there check ok. i checked a few out of circuit and they checked fine

Perry Babin 21st April 2012 10:09 AM

Did you measure the DC voltage across the relay coil to see if it had 12v?

Did you follow it back to see if there was a break in the trace or some other component in the circuit that's defective?

timwebb 22nd April 2012 10:40 PM

there is about 1v on the relay coil. i didnt find and broken traces.. all the other traces have glue on them. which transistor on the ps board turns the relays on?

timwebb 22nd April 2012 11:12 PM

ok there is a faint sound coming from the relay.could it be bad?

Perry Babin 23rd April 2012 02:34 AM

The relay will need at least 8-9v to engage.

If there are no other components between the driver board and the relay, use your meter to find continuity between the relay coil pins and the driver board pins. From there trace the circuit on the driver board.


All times are GMT. The time now is 09:01 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2