Rockford Power 550X 4 Channel - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th March 2012, 08:37 PM   #1
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Default Rockford Power 550X 4 Channel

Hello all. I have a Rockford Power 550X I am working on with a small issue.

The board number is PC-3094-E.

When it came in it had no audio. I replaced the RCA jacks and D2 and D3.

The amp powers up fine and idles fine, no current draw or anything unusual.

All channels bias fine and produce clean audio.

However....The right rear negative bridging terminal has -1.836 vdc on it.

The only time I notice a problem is running it bridged. At low or no volume it is very staticy. Once the volume is increased it sounds totally fine.

I am kinda stumped here as in where to look for a problem.

Anybody have any ideas?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 26th March 2012, 10:02 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you have the same voltage on the two bases of the differential amplifier transistors?
  Reply With Quote
Old 26th March 2012, 10:41 PM   #3
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
As in Qx105 and Qx106?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 27th March 2012, 12:02 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Qx01 and Qx02.
  Reply With Quote
Old 29th March 2012, 02:57 AM   #5
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
All the bases read the same: 0.047 vdc except Q301 and Q302.

Q301 reads -1.285 vdc

Q302 when tested showed about 0.533 vdc but made the amp draw 20 amps on my supply and screech.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 1st April 2012, 12:22 AM   #6
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Hey Perry did you get a chance to read my last post?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 2nd April 2012, 08:41 PM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What is the DC voltage measured directly across the following resistors. I would ask for them in smaller groups but I haven't had much time to visit the forum.

R317-R323 and R326.
  Reply With Quote
Old 3rd April 2012, 04:15 AM   #8
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
R317: 0.039 vdc
R318: 0.040 vdc
R319: 4.82 vdc
R320: -0.361 vdc
R321: 0.378 vdc
R322: -1.152 vdc
R323: -0.534 vdc

R326: 0.525 vdc
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 3rd April 2012, 05:34 PM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I don't see anything there that's unexpected.

With the black probe on the negative speaker terminal, what's the DC voltage on the 4 terminals of C312 and C314?
  Reply With Quote
Old 23rd May 2012, 05:46 AM   #10
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Hello Perry its been awhile since I posted on this not sure if you remember where we were at.

Black probe on negative speaker terminal and red probe on

C312: 0.946 vdc
C312: 2.574 vdc

C314: 1.248 vdc
C314: 3.145 vdc

Let me know what you think.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford fosgate 550x mike49504 Car Audio 15 10th June 2011 05:11 AM
rockford 501s one bad channel stoke Car Audio 18 23rd February 2011 04:43 PM
Rockford fosgate 550x mike49504 Car Audio 1 11th February 2011 12:30 PM
Rockford Power 550x bias issue brandes.cm Car Audio 5 24th November 2009 01:13 PM
rockford fosgate 550x mike49504 Car Audio 21 6th December 2008 10:26 PM


New To Site? Need Help?

All times are GMT. The time now is 07:19 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2