Punch 500a2 messed up channel - Page 3 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd April 2012, 03:55 AM   #21
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you lift Q109 and Q111, does that allow the bias to work properly?
  Reply With Quote
Old 3rd April 2012, 04:25 AM   #22
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
No, I see no rise in current with those removed.
  Reply With Quote
Old 3rd April 2012, 05:36 PM   #23
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What's the DC voltage on the collectors of Q123 and Q120?
  Reply With Quote
Old 4th April 2012, 12:29 AM   #24
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Q123 collector -41.21Vdc
Q120 collector +41.1Vdc
  Reply With Quote
Old 4th April 2012, 07:49 PM   #25
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you have 0v across the speaker terminals (Q109, Q111 and D104 out of the circuit), connect a jumper between the collector and the emitter of Q122. Does that drive full negative rail to the speaker terminals on that channel?

Q123 may need to be lifted to ensure that it's not damaged.
  Reply With Quote
Old 5th April 2012, 02:17 AM   #26
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
I get -34Vdc on the speaker terminals, that's with Q109, Q111, D104 and Q123 removed.
  Reply With Quote
Old 5th April 2012, 11:20 AM   #27
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Remove the jumper between Q122's terminals. Reinstall Q123 and confirm that you have 0v on the output. If so, short the base of Q122 to the collector. Does that again give you negative rail on the output?
  Reply With Quote
Old 5th April 2012, 12:00 PM   #28
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
I have zero when Q123 is populated and no jumper from collector to emitter and -35.5Vdc when the base to collector is jumpered.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 6th April 2012, 12:44 AM   #29
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
That means that the drivers are able to drive the outputs to produce the bottom half of the waveform.

With no jumpers and the bias fully clockwise, what's the voltage between the bases of the drivers (Q120 and Q121, Q122 and Q123)?
  Reply With Quote
Old 6th April 2012, 12:49 AM   #30
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
-2.4Vdc between Q120 and Q121
-1.7Vdc between Q122 and Q123

Last edited by brandes.cm; 6th April 2012 at 12:51 AM. Reason: measured wrong place
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford punch 500a2 chipper Car Audio 45 10th February 2012 01:55 AM
Distorted LF channel on punch 200a4 chipper Car Audio 5 23rd September 2011 03:50 AM
Rockford Fosgate Punch 500x 4 channel seankane Car Audio 48 29th April 2011 10:46 PM
Punch 500a2 distorted channel chipper Car Audio 62 21st March 2011 09:02 PM
Punch 40DSM no output on either channel brandes.cm Car Audio 33 27th June 2010 04:52 AM


New To Site? Need Help?

All times are GMT. The time now is 10:07 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2