Punch 500a2 messed up channel - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th March 2012, 11:24 AM   #11
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Those are with it installed. It doesn't measure shorted.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 27th March 2012, 11:25 AM   #12
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It needs to remain out of the circuit.
  Reply With Quote
Old 29th March 2012, 01:36 AM   #13
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
D104 once again removed and will not go back in until repair is complete.

The signal is squared off right after the differential amplifier pair, Q102, Q103.
  Reply With Quote
Old 3rd April 2012, 02:09 AM   #14
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
What am I missing? The lower half of the signal is missing on the output, but the IRF9540's are missing the gate signal.

Edit**
The differential pair are the only two discrete's that haven't been replaced.

Last edited by brandes.cm; 3rd April 2012 at 02:26 AM.
  Reply With Quote
Old 3rd April 2012, 02:43 AM   #15
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Does the biasing work for that channel?
  Reply With Quote
Old 3rd April 2012, 02:55 AM   #16
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Doesn't appear to be. I can adjust the working channel and see the current increase in my supply.
  Reply With Quote
Old 3rd April 2012, 02:57 AM   #17
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
With the bias fully clockwise, what is the voltage on the IRF540s (black probe on the source, red probe on the gate)?

What's the voltage on the IRF9540s (same probe orientation)?
  Reply With Quote
Old 3rd April 2012, 03:02 AM   #18
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
IRF540 3.24Vdc
IRF9540 -1.21Vdc
  Reply With Quote
Old 3rd April 2012, 03:19 AM   #19
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The 9540 isn't being driven on. Post the DC voltage across R160 and R133.
  Reply With Quote
Old 3rd April 2012, 03:29 AM   #20
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
R160 14.78Vdc
R133 -.72Vdc
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford punch 500a2 chipper Car Audio 45 10th February 2012 01:55 AM
Distorted LF channel on punch 200a4 chipper Car Audio 5 23rd September 2011 03:50 AM
Rockford Fosgate Punch 500x 4 channel seankane Car Audio 48 29th April 2011 10:46 PM
Punch 500a2 distorted channel chipper Car Audio 62 21st March 2011 09:02 PM
Punch 40DSM no output on either channel brandes.cm Car Audio 33 27th June 2010 04:52 AM


New To Site? Need Help?

All times are GMT. The time now is 01:52 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2