Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Punch 500a2 messed up channel
Punch 500a2 messed up channel
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th April 2012, 03:45 AM   #41
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Hmm, wonder if I should check the .1ohm resistors. Hey looky there, 3 are open and the other 3 read high. Man I wasted everyone's time.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 6th April 2012, 03:07 PM   #42
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
I guess that wasn't the whole issue, since bias won't adjust unless I lift D104. I also have a full sinewave with it lifted. Something is still tripping the protect circuit. Q116-118, R162 and D105 have been replaced.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 6th April 2012, 04:58 PM   #43
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Will the amp produce a clean rail to rail sine wave with a load with D104 lifted?
  Reply With Quote
Old 6th April 2012, 05:08 PM   #44
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Yes all looks good when D104 is lifted.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 7th April 2012, 07:41 AM   #45
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Reinstall D104. Remove and then replace the following transistors, one at a time in the order listed. Which one is the first to allow the amp to play when it's out of the circuit.

Q118, Q117, D116
  Reply With Quote
Old 7th April 2012, 01:38 PM   #46
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Q118 showed a sawtooth waveform, not a nice sine.

Q117 allowed full sinewave.



sent from an IRFZ48N
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator

Last edited by brandes.cm; 7th April 2012 at 01:58 PM. Reason: added Q118 comment
  Reply With Quote
Old 9th April 2012, 09:51 AM   #47
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Reinstall all of those parts and remove R157. Does that allow the amp to produce clean audio?
  Reply With Quote
Old 9th April 2012, 12:50 PM   #48
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
With R157 removed I have a sinewave.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 9th April 2012, 11:41 PM   #49
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It appears that the fault is in the DC offset protection circuit.

Check the following and confirm that you have the 14 on the diodes.

D103
D105
R127
R129
R130
R147
R156
  Reply With Quote
Old 10th April 2012, 01:10 AM   #50
brandes.cm is offline brandes.cm  United States
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
All check ok, diodes show correct voltage.

With a signal being input and a 3 ohm load Q113 gets hot in a short period of time(about 30 seconds).
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote

Reply


Punch 500a2 messed up channelHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford punch 500a2 chipper Car Audio 45 10th February 2012 02:55 AM
Distorted LF channel on punch 200a4 chipper Car Audio 5 23rd September 2011 04:50 AM
Rockford Fosgate Punch 500x 4 channel seankane Car Audio 48 29th April 2011 11:46 PM
Punch 500a2 distorted channel chipper Car Audio 62 21st March 2011 10:02 PM
Punch 40DSM no output on either channel brandes.cm Car Audio 33 27th June 2010 05:52 AM


New To Site? Need Help?

All times are GMT. The time now is 05:44 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki