Kicker ZX1000.1 No Sound! Need some help please. - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th March 2012, 05:20 PM   #1
diyAudio Member
 
Join Date: Mar 2012
Location: Oklahoma
Default Kicker ZX1000.1 No Sound! Need some help please.

I have this Kicker amp. Its powers up and has green light, the relay clicks. I have checked the PTs they are not shorted. There is rail voltage 119volts. Nothing is burnt. dont have a O-scope or a temp probe. dont know which transistors are the audio drivers on this amp. Check for cold solder joints on all the boards. Nothing. All help is highly appreaciated. I have read the other posts on this amp and have went as far as I know how to with the limited knowledge that I have.
  Reply With Quote
Old 20th March 2012, 05:38 PM   #2
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Verify the relay contacts are good. I just replace a relay in a kicker amp that the contacts were completely burned. It still engaged, just didn't flow and current.
  Reply With Quote
Old 20th March 2012, 06:26 PM   #3
diyAudio Member
 
jeanious2011's Avatar
 
Join Date: Nov 2010
Location: Texas
Check the fuse by the RCA inputs its a SMD fuse so you'll have to look very closely and carefully. If am not mistaking its labled F5 on the board.
  Reply With Quote
Old 20th March 2012, 10:05 PM   #4
diyAudio Member
 
Join Date: Mar 2012
Location: Oklahoma
can't locate any fuses on the rca board. And the relay checked out good.
  Reply With Quote
Old 21st March 2012, 02:04 AM   #5
diyAudio Member
 
jeanious2011's Avatar
 
Join Date: Nov 2010
Location: Texas
So your are getting signal through the relay? Check both input and outputs of the relay to make sure the signal is the same.

Sometimes the ground break off of the RCA's (if its the RCA jack is solder to the board they usually break from force). If its the RCA's with the wire to the board than those last a lot longer than the others.

There is a fuse on the the old kickers (cant remember which models) that was on the ground trace of the RCA's once that one break your input signal is not complete and the output is very very low or non.
  Reply With Quote
Old 21st March 2012, 04:25 AM   #6
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Just ohm from rca shield to amp ground, it should read some value. If not look on the bottom of the board for the fuse.
  Reply With Quote
Old 21st March 2012, 04:43 AM   #7
diyAudio Member
 
Join Date: Mar 2012
Location: Oklahoma
ground is good on rca's. All I could do is ohm through the relay for continuity and it passed. Called an old friend that owned the old repair shop where I worked and he said he had a o-scope that I could have for all the good service I gave them. Scope will be picked up this weekend. All these checks are good points to check, Still brainstorming. On one note I noticed that the FETS on the power supply are all of mixed batches. I seem to be the first into this amp so I guess that Kicker uses all of different batches not matched sets. Hmmm. I guess they work just maybe not as efficient as they could.
  Reply With Quote
Old 21st March 2012, 07:01 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What is the revision number on the main board (rev1.?)?
  Reply With Quote
Old 21st March 2012, 03:36 PM   #9
diyAudio Member
 
Join Date: Mar 2012
Location: Oklahoma
rev1.4
11.01.05
  Reply With Quote
Old 22nd March 2012, 10:39 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
With the amp on, what's the resistance between the inductor terminal nearest the L101 marking and the positive speaker terminal?

If your meter cannot handle voltage when set to ohms, confirm that there is no voltage between those points before measuring the resistance.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicker zx1000.1 question bigpun4fubu Car Audio 10 25th May 2013 12:04 PM
Kicker ZX1000.1 repair djQUAN Car Audio 99 16th August 2012 08:50 AM
Kicker zx1000.1 no sound¡ ray9043 Car Audio 53 18th April 2012 04:57 AM
kicker zx1000 timwebb Car Audio 0 19th July 2011 01:53 AM
Kicker zx1000.1 repair question TonyK2003 Car Audio 5 9th January 2010 06:43 AM


New To Site? Need Help?

All times are GMT. The time now is 06:25 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2