hifonics bxi2010d - Page 4 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th April 2012, 11:10 AM   #31
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
They are both MMBTA42s. They're marked 1D.
  Reply With Quote
Old 14th April 2012, 03:07 AM   #32
DREW028 is offline DREW028  United States
diyAudio Member
 
Join Date: Jun 2004
Location: chicago
Send a message via AIM to DREW028
Just got done replacing the transistors. Amp works now. I just have to order the clips.


Thanks for everyone's help.
  Reply With Quote
Old 15th April 2012, 01:31 AM   #33
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
When you get the clips, post where you purchased them from and how they fit.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics BX1205D m4ick Car Audio 15 22nd October 2012 02:01 PM
Hifonics Eagle Dr Zeus Car Audio 3 17th May 2011 02:07 AM
Hifonics dtisme Car Audio 3 7th August 2010 12:49 AM
hifonics 1606d dtisme Car Audio 9 2nd August 2010 09:17 PM
Hifonics Brutus lee1976 Car Audio 3 20th July 2010 11:19 AM


New To Site? Need Help?

All times are GMT. The time now is 05:46 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2