Hifonics Brutus BXi1600D does not power up - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th March 2012, 05:19 PM   #11
Mote is offline Mote  Estonia
diyAudio Member
 
Join Date: Jul 2010
Location: Estonia
Never mind.
TIP41C had also broken leg, that was switching amp on and off. After replacing it I can bend and twist and push on the board as much as I like but I can not get it to turn off.

One of the outputs had shorted, I missed it earlier because I measured resistance on the pads of outputs, it was prior to repairing the broken legs. It was one with broken leg so when I checked it there was no contact to the transistor. I missed all the broken legs because I did not want the heatsink compound on my hands and scope wires etc and I wrapped all of the transistors in tape.

I removed all of the outputs, power LED is green. I get nice square on pin 5 of 4080, triangle on pin 6 and squares on pins 11, 13, 18 and 20. I assume that 4080 is working properly.

I order all new outputs and see what happens then.
__________________
Tools: Perrys tutorial, C1-76 o-scope, Weller WHS40, Mastech MAS830L multimeter, Mastech MY6243 LC meter, 16A supply
  Reply With Quote
Old 14th March 2012, 07:39 PM   #12
Mote is offline Mote  Estonia
diyAudio Member
 
Join Date: Jul 2010
Location: Estonia
Replaced all outputs, amp is working just fine.
__________________
Tools: Perrys tutorial, C1-76 o-scope, Weller WHS40, Mastech MAS830L multimeter, Mastech MY6243 LC meter, 16A supply
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics Brutus 1206D Dr Zeus Car Audio 4 31st October 2011 01:05 PM
hifonics brutus BXI1500D elev8rsh0es Class D 1 8th February 2011 04:47 PM
Hifonics Brutus lee1976 Car Audio 3 20th July 2010 11:19 AM
Hifonics Brutus BX1500D FireII Car Audio 5 24th May 2010 03:08 AM
hifonics brutus bxi1206d ray9043 Car Audio 2 30th March 2008 05:36 AM


New To Site? Need Help?

All times are GMT. The time now is 05:42 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2