kicker ZX750.1 problem (similar to other thread but slightly different) - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th March 2012, 09:31 PM   #1
diyAudio Member
 
Join Date: Mar 2012
Default kicker ZX750.1 problem (similar to other thread but slightly different)

I was in my truck listening to some music and I have the Kicker ZX750.1 amp. Amp still powers up normally but with no output. The only difference in it's power up cycle now from when it was working properly is there used to be an audible click when the amp was fully powered up and it began producing audio, and it no longer does this. It was playing fine and I shut the truck off and turned the key to accessory and now nothing. It had done this once before and after about 10 minutes of no output, I heard it click and it was playing again. No such luck this time. Could this be a relay or what do you guys think?
  Reply With Quote
Old 8th March 2012, 02:48 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It's not likely to be a faulty relay. Is the amp in protect mode?
  Reply With Quote
Old 8th March 2012, 05:38 AM   #3
diyAudio Member
 
Join Date: Mar 2012
No, the amp is not in protect mode. the light starts red and fades to green like it always has, just without the click that normally proceeds the green light. It was pushing two 10” cvrs beautifully and I shut the ignition off and cycled to acc. And suddenly no audio.
  Reply With Quote
Old 9th March 2012, 12:31 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you want to try it yourself, read the basic amp repair page (link in sig line below) from top to bottom, including the parts you don't think are necessary. Let us know when you've done that.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need schematic for kicker zx750.1 no1stunna Car Audio 19 11th January 2012 04:10 PM
Kicker ZX750.1 Powers Up (green Light) No Sound bigpun4fubu Car Audio 43 13th November 2011 11:51 PM
Need help with no sound from kicker zx750.1 amp kylelemay1 Class D 0 7th May 2011 04:46 PM
Kicker zx750.1 texasrebel1 Car Audio 2 10th January 2009 04:46 PM
Kicker zx750.1 solobaric 10's texasrebel1 Car Audio 2 5th December 2008 01:27 AM


New To Site? Need Help?

All times are GMT. The time now is 05:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2