Kenwood 9152D Mods - Possible? - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd March 2012, 11:32 AM   #1
diyAudio Member
 
Join Date: May 2011
Default Kenwood 9152D Mods - Possible?

I had 2 of these Kenny amps and have recently sourced a 3rd. I am looking to get a forth and run 2 strapped per coil on my XXX15.
The one I just picked up had the same problem as the last one with not powering up, I opened it and replaced W17.
If earthing the chassis makes the amplifier switch on, this is usually the problem.

Anyway. I noticed on this board C15 & C199 are missing (slightly different revision to my other 2) so I was looking at fitting these.

The main reason for this thread is, does anybody have any idea about any possible mods I could make?
They are rated at 900w rms @ 2ohm but are 1ohm stable. I ran mine @ .7ohm each and they barely got warm. They are only fitted with 2x30A fuses and I believe that this is a limiting factor in their performance.
The fuses do pop when you push it for too long. I would like to fit a pair of 35A maybe 40A fuses as they seem to pop before they clip??? (Crossover @ <70Hz)

They are cheap @ 25-60 GBP so it wouldn't be the end of the world if one failed.
Is there anything I should be thinking about before just adding bigger fuses? Maybe better FET's?

I am open to any advice or thoughts can upload higher resolution pictures if required.
Thank you
  Reply With Quote
Old 2nd March 2012, 11:44 AM   #2
diyAudio Member
 
Join Date: May 2011
Click the image to open in full size.
  Reply With Quote
Old 2nd March 2012, 06:18 PM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I'd suggest running them until one fails. The component that fails is likely the weakest link and you can start by looking at modifying that part of the amp first.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood Basic C2 preamp mods jason12 Solid State 7 8th November 2012 04:57 PM
KAC-9152D Kenwood - No Power kmil Class D 15 21st December 2010 03:07 PM
kenwood ps500F damage Car Audio 2 23rd August 2008 06:02 PM
Kenwood thunder Chip Amps 3 20th February 2007 12:58 PM
PLEASE! Kenwood help! mjarve Solid State 1 23rd September 2004 05:04 AM


New To Site? Need Help?

All times are GMT. The time now is 02:20 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2