diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   autotek xs1500.1 (http://www.diyaudio.com/forums/car-audio/207909-autotek-xs1500-1-a.html)

DREW028 1st March 2012 07:55 PM

autotek xs1500.1
 
Does anyone know the part number is for the power supply FET's?


Also Perry i seen in another one of your post you recommended changing the output FETS to the IRF3710Z?

Perry Babin 1st March 2012 09:22 PM

IRFP064N in the power supply.

Only use the IRF3710Z if the output transistors have failed and you need replacements.

DREW028 2nd March 2012 01:39 AM

2 failed so I guess ill have to replace them all.

Thank You!

This amp also had 2 more added resistors soldered in at locations r37 and r40. Do you know if this modifies the protection for the amp? Also r39 location is empty, should it be?

Perry Babin 2nd March 2012 09:20 AM

The parallel resistors are OK. R39 should be the same as R38.

DREW028 4th March 2012 02:11 AM

With the new output FETs would it be ok to run it with the protection modded?

DREW028 4th March 2012 04:09 AM

Have you ever used or heard about avnetexpress? They have the irf3710z for $.58 and a few other FETs i need for cheap.

Perry Babin 4th March 2012 06:02 PM

I don't know precisely how the protection circuit has been modified so I can't tell you it would be safe. I'd guess it would not since it failed to protect the outputs.

I don't buy from that distributor. I generally recommend Future, Arrow, Digi-key and Mouser.

DREW028 9th March 2012 12:41 AM

Output FETs are out as well as the rectifiers.


Just installed the power supply FEts and everything seems ok.

i see this amp doesn't have a negative rail on the power supply am i correct?

On the outside pins of the rectifiers im reading +32vAC (on both rectifiers). Center leg to the outside legs im reading +15vAC (both rectifiers). Does this sound right?

I haven't gotten the replacement output FETs yet. Hopefully soon, i am very excited to see this amp work. Thank you!

How do i check IC6 and IC5? I downloaded the datasheet but am not sure what reference to ground to use.

Perry Babin 9th March 2012 12:50 AM

The amp only has positive rail voltage for the output transistors. I've never needed to measure the voltage the way you did so I don't know if it's right.

DREW028 9th March 2012 02:11 AM

No outputs fets, rectifiers in 63.5vDC on center leg (both rectifiers) black probe on amp ground.


All times are GMT. The time now is 05:00 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2