Kicker ZX450.2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th February 2012, 12:17 AM   #1
diyAudio Member
 
Join Date: Sep 2006
Default Kicker ZX450.2

Amp is stuck in protection mode..

Heres what i have on the 494

Pin 1:1.23
Pin 2:3.68
Pin 3:4.74
Pin 4:6.63 and keeps climbing
Pin 5:1.48
Pin 6:3.39
Pin 7:0
Pin 8:0.26
Pin 9:0
Pin 10:0
Pin 11:0.27
Pin 12:13.90
Pin 13:5.00
Pin 14:5.00
Pin 15:5.00
Pin 16:12.79

Thoose readings are with the rectifiers out of circuit..

Any ideas??
  Reply With Quote
Old 26th February 2012, 11:34 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a photo of the board. I don't have any information on that amp.
  Reply With Quote
Old 27th February 2012, 12:16 AM   #3
diyAudio Member
 
Join Date: Sep 2006
Heres a couple pics of the board..
Attached Images
File Type: jpg Kicker 1.JPG (581.4 KB, 36 views)
File Type: jpg kicker 2.JPG (469.2 KB, 37 views)
  Reply With Quote
Old 27th February 2012, 12:33 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There are two long jumpers for the protection circuit. Pull them one at a time to see which one is causing the amp to go into protect.

Clamp all transistor and use a current limiter. The amp may try to draw excessive current.
  Reply With Quote
Old 27th February 2012, 11:25 PM   #5
diyAudio Member
 
Join Date: Sep 2006
I pulled the 2 jumpers circled in blue amp still doesnt power up..


Pin 16 of the 494 is still at 12.89 volts..
Attached Images
File Type: jpg Kicker 3.JPG (584.5 KB, 26 views)
  Reply With Quote
Old 28th February 2012, 11:39 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What's driving pin 16?

If it goes back to a transistor, pull that transistor.
  Reply With Quote
Old 28th February 2012, 10:58 PM   #7
diyAudio Member
 
Join Date: Sep 2006
I pulled Q1 (A1359) and followed the trace in the other direction as well and pulled Q6 ..

Both transistors are connected to pin 16..

I got the voltage to drop to 4.36 volts on pin 16 amp is still dead..
  Reply With Quote
Old 29th February 2012, 12:45 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If pin 15 is still at 5.0v, something else is also causing the IC to shut down. Post the voltages again or at least the ones that have changed.
  Reply With Quote
Old 29th February 2012, 12:58 AM   #9
diyAudio Member
 
Join Date: Sep 2006
I put Q1 back in the amp and this is what i get now..

Pin 1:0.83
Pin 2:2.39
Pin 3:0.06
Pin 4:0
Pin 5:1.48
Pin 6:3.40
Pin 7:0
Pin 8:12.01
Pin 9:5.01
Pin 10:5.01
Pin 11:12.01
Pin 12:13.88
Pin 13:5.00
Pin 14:5.00
Pin 15:5.00
Pin 16:4.36

Last edited by mike49504; 29th February 2012 at 01:04 AM.
  Reply With Quote
Old 29th February 2012, 12:59 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What are the numbers on the transistors?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kicker kx1200.1 getmoney2957 Class D 1 7th July 2012 11:24 PM
Kicker ZX450.2 m4ick Car Audio 9 18th January 2012 11:26 PM
phoenix gold ZX450 problem NauTech Car Audio 11 9th April 2011 06:22 AM
kicker zx100.2 spaz1980 Car Audio 8 21st September 2009 05:21 PM
Kicker SX650.1 help shagone Car Audio 12 19th March 2008 07:35 AM


New To Site? Need Help?

All times are GMT. The time now is 06:00 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2