another kicker kx1200.1 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th February 2012, 09:51 AM   #1
diyAudio Member
 
Join Date: Sep 2010
Location: usa washington state
Default another kicker kx1200.1

i have a kx1200.1. a couple years ago i blew a sub powered by this amp. after sub blew amp blew as well. . so, i tested here n there with dmm. i ended up having some of output and power supply transistors blown. and a couple gate resistors.
so. i changed all the transistors and gate resistors with new replacements exact match of what was in. and tested again, everything looks good. but im, kinda of, new to repairing.. ive been trying for years and have only recently had any luck.
when i tried to power it up after repairing the parts i cannot get anything from amp. no power no protection light. nothing.
i wanted to ask on here if someone could give me some advice on what to check for . im trying to figure out what to check to find out why it wont power up. i figured at least it would power and possibly blow somthing else maybe or work . but it does nothing. wiring is good , i have other amps that work fine on wires

can someone tell me what i should check for power into amp
  Reply With Quote
Old 17th February 2012, 10:31 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post the DC voltage on all pins of the TL494. Copy and paste the following into your post.

IC#
Pin 1:
Pin 2:
Pin 3:
Pin 4:
Pin 5:
Pin 6:
Pin 7:
Pin 8:
Pin 9:
Pin 10:
Pin 11:
Pin 12:
Pin 13:
Pin 14:
Pin 15:
Pin 16:
  Reply With Quote
Old 19th February 2012, 07:42 AM   #3
diyAudio Member
 
Join Date: Sep 2010
Location: usa washington state
ok. i am reading up nowon how to convert pc power supply into 12v supply , as that is my only option to power my amps to test ,besides running back and forth to car or bring battery inside. i dont want to do that as i am constantly working on amplifiers. as soon as i can get that made i will test and post my voltages. thank you for your help. perry you are awesome. thank you so much for the knowledge you share.
  Reply With Quote
Old 19th February 2012, 08:02 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You don't need to do anything to make the power supply produce 12v, except maybe load the 3.3 or 5v output. Connecting the green and black wires on an ATX power supply will make the supply turn on and have output from all pins. The only real advantage of modifying one is that you'll have a bit more voltage and a bit more stable voltage.
  Reply With Quote
Old 20th February 2012, 08:25 AM   #5
diyAudio Member
 
Join Date: Sep 2010
Location: usa washington state
thanks for the info . the power supply i had around says hipro. says 12v at 8 amps. dont know how it compares to atx but colors match the site that i am following instruction on. all i really want to do with it is make it a useable 12v source for powering up amps and decks to test basicly . dont need it to do anything else. but site i was on called it modifying to use as bench power supply. so kinda how i said it.probably will have it done tomarrow and then will be able to use it and test im hoping. will post my results asap
  Reply With Quote
Old 22nd February 2012, 05:14 AM   #6
diyAudio Member
 
Join Date: Sep 2010
Location: usa washington state
ok. i got the power supply finished. i checked it over and tested it a few times just to be sure i didnt make any mistakes . i also tested a couple good amps to make sure it worked correctly. works great.
now . i hooked up kicker 1200.1 to it. i jumped the remote wire from 12v . .i get " 0v " on every pin on the tl494c.

i checked with dmm . at b+ terminal on amp , i get 11.82 volts ,which is what the ps puts out at its b+ terminal with fan,(without fan it puts out around 12.08v. ) on circuit board i get the 11.82 volts on the b+ circuit... it goes from that part of circuit to a diode?? I THINK ITS A DIODE( D01 LOCATION ON BOARD) on the side of that (d01) that is in contact with b+ circuit i get the 11.82v, but when i put dmm on the opposite side of (d01) i get nothing. i was thinking it may be a 1 direction diode that has blown possibly?? but i dont know becouse i am unsure of how to test that component...
also directly off of the same b+ circuit but on the other side nerer to ground there is a component (co1 location on board) that is same ... it tests 11.82 on the b+ side of this component but ov on the other side so maybe that (c01) is blown?? i am unsure of this
i put the 12v into amp but seems to stop right about b+ terminal on amp. any ideas would be VERY APPRECIATED.
  Reply With Quote
Old 22nd February 2012, 05:17 PM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Does this amp have a red or green board?
  Reply With Quote
Old 22nd February 2012, 07:37 PM   #8
diyAudio Member
 
Join Date: Sep 2010
Location: usa washington state
it has the red board.
  Reply With Quote
Old 22nd February 2012, 08:44 PM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Voltage on all 3 legs of Q01?

Voltage on each end of R01?
  Reply With Quote
Old 22nd February 2012, 09:54 PM   #10
diyAudio Member
 
Join Date: Sep 2010
Location: usa washington state
ok looking at the 3 leg side of Q01 from left to right i get 11.77v 0v 11.83 .. on top of Q01 in middle there is another tab?? with solder on it, i get 0v there as well
And R01, i get 11.82 v on both ends..
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kicker kx1200.1 getmoney2957 Class D 1 7th July 2012 11:24 PM
kicker kx1200.1 timwebb Car Audio 8 24th January 2012 02:38 AM
Another fried Kicker KX1200.1 olftboy Car Audio 25 5th September 2010 04:31 PM
Kicker kx1200.1 catfishermike Car Audio 3 18th April 2010 02:50 AM
Kicker KX1200.1 went up in smoke phil33875 Car Audio 10 25th March 2010 01:37 AM


New To Site? Need Help?

All times are GMT. The time now is 09:26 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2