Kicker KX350.2 Dead - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th January 2012, 05:29 PM   #1
diyAudio Member
 
Join Date: Oct 2011
Default Kicker KX350.2 Dead

I have a kicker KX350.1 that is dead. When I apply remote voltage to the amp it does nothing. I have 12v on the drain leg of my p.s. fet's, but no voltage on the gate's. I have verified that the remote terminal is making contact. I have checked the tl494cn and found 0 volts on every leg except 18, which reads 3 volts. The i.c. reads the same with or without remote voltage applied. I know that the remote terminal has a good connection because I was able to follow the 12v through a zener where it was regulated to 6v. After that it is hard to tell where it goes. I have searched the power supply over and have not found any open components. Any insight is appreciated.
  Reply With Quote
Old 30th January 2012, 06:34 PM   #2
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Do you have B+ applied too? You should have +12 and a +5V reference on the TL494. The 5V reference is generated from the TL494, if you don't have +12 on that IC you won't have gate signals. What are the exact voltages on the TL494?
  Reply With Quote
Old 30th January 2012, 09:01 PM   #3
diyAudio Member
 
Join Date: Sep 2006
Im working on the same amp right now.. With the same problem I will let you know what i find ..
  Reply With Quote
Old 31st January 2012, 01:35 AM   #4
diyAudio Member
 
Join Date: Oct 2011
yes , I had everything connected as if the amp was installed. It is acting like it's not getting a signal from the remote. The ic reads 0volts on all legs except 18. This is putting negative probe on the ground block and putting positive on each leg of the ic. I read where another ground is used in some amps but even when I use the wire that grounds to the heatsink I get the same readings. I have 12v on the drain leg. I read 0volts on the gate.
  Reply With Quote
Old 31st January 2012, 02:09 AM   #5
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
u check the pwm?
  Reply With Quote
Old 31st January 2012, 03:02 AM   #6
diyAudio Member
 
Join Date: Oct 2011
I am just now starting to learn ic's, but I thought there has to be an input voltage to see any pwm? I also do not have a scope. I do have a radioshack multimeter with the pc-interface and a pulse width selection. I still have not figured out how to display scope info but if you could direct me on what to look for I can give it a shot.
  Reply With Quote
Old 31st January 2012, 04:45 AM   #7
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Post the voltages on all pins. Black goes to gnd block.
1)
2)
3)
Etc....

Sent from my Punch 60.2
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 31st January 2012, 03:26 PM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is there a relatively large transistor near the 494 that has it's center leg connected to pin 12 of the IC?

If so, post the voltage on all legs of that transistor.
  Reply With Quote
Old 31st January 2012, 05:46 PM   #9
diyAudio Member
 
Join Date: Oct 2011
Yes, the transistor I found is Q1/b649 a. If the datasheet I found is the right one, then the pinout is e,c,b, I have 12v on the emitter, 0v on the collector, and 12v on the base.
  Reply With Quote
Old 31st January 2012, 07:54 PM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post the voltage on Q2. It should be an NPN transistor with it's center leg connected to the 3rd leg of Q1 via a resistor.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Dead Laser Pickups - why not replacing the Diode only? Salar Digital Source 20 24th July 2013 10:34 PM
Kicker 2500.1 mike49504 Car Audio 13 7th February 2011 07:30 AM
Kicker ZX2500.1 Dr Zeus Car Audio 19 27th January 2011 10:41 PM
Kicker DX350 Dr Zeus Car Audio 9 18th January 2011 12:13 AM
Kicker ZX460 mike49504 Car Audio 5 2nd January 2011 07:10 AM


New To Site? Need Help?

All times are GMT. The time now is 08:35 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2