Eclipse DA6213 repair - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th January 2012, 08:43 PM   #1
DcMaN is offline DcMaN  United States
diyAudio Member
 
Join Date: Aug 2010
Default Eclipse DA6213 repair

hello, im currently having some issues with an Eclipse DA6213. I was hoping some one could help me trouble shoot it. The amp powers on, but the green light does not come on and does not produce any audio output. Ive checked on the board and everything appears to be in tact and in good standing. Fets look good, nothing looks out of the ordinary. Any help is appreciated.

Thanks

-Rob
  Reply With Quote
Old 24th January 2012, 08:46 PM   #2
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
got a picture?
  Reply With Quote
Old 24th January 2012, 09:16 PM   #3
DcMaN is offline DcMaN  United States
diyAudio Member
 
Join Date: Aug 2010
I shorted out a power supply fet by mistake last night. But even prior to that the green light never came on and had no audio output. You can see it , the second one in on the top right hand side.


Click the image to open in full size.
Attached Images
File Type: jpg photo.jpg (686.6 KB, 55 views)

Last edited by DcMaN; 24th January 2012 at 09:37 PM.
  Reply With Quote
Old 24th January 2012, 09:47 PM   #4
DcMaN is offline DcMaN  United States
diyAudio Member
 
Join Date: Aug 2010
Ive checked the voltage on the rails by the power / ground terminals, all is well there, however when i check the rails for voltage by the power supply fets, i dont get any reading
  Reply With Quote
Old 24th January 2012, 10:04 PM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you read 0, 12 and 0v on the legs of all of the power supply FETs?

Have you checked the output transistors to see if any are shorted?
  Reply With Quote
Old 25th January 2012, 12:27 AM   #6
DcMaN is offline DcMaN  United States
diyAudio Member
 
Join Date: Aug 2010
i checked the fets and they did read 0-12-0v on all untill i shorted one out. Whats the easiest way to check the output transistors ?
  Reply With Quote
Old 25th January 2012, 12:38 AM   #7
ivkata is offline ivkata  United States
diyAudio Member
 
Join Date: Dec 2010
remove the fet u shorted .power supply is not starting unit will not power on
what chip does it use for the psu .
  Reply With Quote
Old 25th January 2012, 01:05 AM   #8
DcMaN is offline DcMaN  United States
diyAudio Member
 
Join Date: Aug 2010
this amp uses NEC K3057 . I wasnt able to find these anywhere. Is there a good substitute to use ?
  Reply With Quote
Old 25th January 2012, 01:18 AM   #9
ivkata is offline ivkata  United States
diyAudio Member
 
Join Date: Dec 2010
its a 2sk3057
check the psu chip what is the part number on it
u don't have and gate voltage
  Reply With Quote
Old 25th January 2012, 05:25 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Do you still read 0, 12, 0 on the power supply FETs?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eclipse 32430 Amp repair 91h22a Car Audio 8 27th May 2011 09:12 PM
Eclipse DA6213 repair ? SIRDRINKSALLOT Car Audio 7 17th January 2009 12:48 AM
Eclipse manual help please rader Car Audio 0 29th October 2006 03:06 PM
Eclipse Brian Donaldson The Lounge 5 28th October 2004 08:32 PM
Eclipse? Larr_e_boy Multi-Way 0 7th June 2001 02:41 PM


New To Site? Need Help?

All times are GMT. The time now is 03:32 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2