MTX Thunder 5601 burnt - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th January 2012, 04:00 PM   #1
diyAudio Member
 
Join Date: Sep 2011
Default MTX Thunder 5601 burnt

IMG_0879.jpgHello...I have a Thunder 5601 with a burnt part on the board...Just wondering if someone hase a picture of the area, or whematic, so I can tell what the parts were...Here is the area..>Thanks
  Reply With Quote
Old 17th January 2012, 07:28 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
CLICK

This is probably one of the 15v regulators. If so, this type of failure often applies high voltage to most of the op-amps and maybe the fan. This can cause a lot of damage.
  Reply With Quote
Old 17th January 2012, 07:46 PM   #3
diyAudio Member
 
Join Date: Sep 2011
Thanks Perry for the picture!...I really appreciate it!...Maybe now I can see how much damage was done!...Thanks Again!
  Reply With Quote
Old 17th January 2012, 08:01 PM   #4
diyAudio Member
 
Join Date: Sep 2011
Hi Perry...Hate to bother you, but do you know what I can use for

q108
q109
c155
c156
c157
d105 -- Cant read the number on this

THANK YOU!!!!!!!...You are awesome
  Reply With Quote
Old 19th January 2012, 06:03 AM   #5
diyAudio Member
 
Join Date: Dec 2011
How did this failure come about?
  Reply With Quote
Old 19th January 2012, 11:21 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The diode is marked H5.

Look up the marking codes to get the part numbers on THIS page. Post the part numbers for confirmation.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MTX Thunder 302 Dr Zeus Car Audio 1 18th December 2011 06:10 AM
MTX Thunder 6500D Burnt Bad CobraTom Car Audio 4 17th September 2011 10:03 PM
MTX 5601 Amp Help Please Kmazzeo26 Car Audio 3 2nd June 2010 08:51 PM
Any help with MTX 5601 amp? Jorel Car Audio 1 31st March 2010 06:35 PM
MTX Thunder 6500D burnt ifrythings Car Audio 10 18th April 2008 05:35 AM


New To Site? Need Help?

All times are GMT. The time now is 11:12 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2