boss rev755 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th January 2012, 03:18 PM   #1
diyAudio Member
 
Join Date: Oct 2010
Default boss rev755

is it acceptable to replace an IRF540N with an IRF540? i've been told that replacing a 540 with 540N will not work sometimes but i'm not sure about the opposite. this one came in with one bank of outputs shorted on each channel. i turned the bias all the way down and checked the drivers and resistors. but when i power up the amp (limited current) the new fets get hot very fast (no audio).
  Reply With Quote
Old 16th January 2012, 03:44 PM   #2
diyAudio Member
 
Osvaldo de Banfield's Avatar
 
Join Date: Dec 2011
Location: Barrio Garay,Almirante Brown, Buenos Aires, Argentina
Verify the driver at the gate of the MOSFET. A bad transistor or diode in the gate can bias the fet at class A or directly into full on condition. I work daily with SMPSīs an motor drivers, and anytime the fet is damaged, the driver also is.

Good luck !!!
__________________
LW1DSE
  Reply With Quote
Old 16th January 2012, 05:32 PM   #3
diyAudio Member
 
Join Date: Oct 2010
i found the problem... i overlooked a bad FET in the output. it wasn't shorted but it was out of tolerance so i replaced that bank of FETs also and now all is good!

thanks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BOSS GE-7 NEW vangelis Instruments and Amps 2 7th July 2011 02:59 PM
boss amplifier cris13fdz Car Audio 4 8th October 2010 07:43 AM
boss amplifier need trasistors cris13fdz Parts 0 6th October 2010 04:19 AM
Boss American amp mike49504 Car Audio 10 12th May 2010 05:13 PM
BOSS Amp soundNERD Car Audio 3 17th August 2004 01:06 AM


New To Site? Need Help?

All times are GMT. The time now is 03:54 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright Đ1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2