Dead 450/4 JL Audio Amp? Need advice - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th December 2011, 05:32 PM   #1
diyAudio Member
 
Join Date: Dec 2011
Default Dead 450/4 JL Audio Amp? Need advice

Hi all, I have a 450/5 JL Audio Amp that stopped working mid-song last year. I was hoping it was just a fuse but when I unscrewed the bottom plate all I could see was madness (or genius if you know what you're doing). Wondering if JL has regular fuses I can try to swap out or if anyone can point me in the right direction. Just trying to avoid paying $180 to send it in over a fuse or something simple... Thanks in advance!!
  Reply With Quote
Old 30th December 2011, 04:05 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You need to confirm that you have sufficient power supply voltage. With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts on either the B+ or remote line, you need to check the wiring feeding whichever line is too low. If 'both' the B+ and remote turn-on lines are low and your battery is fully charged, you may have a bad ground connection.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL Audio 500/5 repair advice, please wjyoung Car Audio 11 28th September 2011 11:42 AM
JL audio 8w6 brought back from dead? bluetjjason Car Audio 3 24th April 2011 01:46 AM
Can I run a 10 inch JL audio and a 12 inch JL audio off same amp ash4kel Car Audio 2 8th April 2011 02:12 AM
JL Audio 10w6v2 or Infinity Kappa 100.3se? Audison SRX4 or Jl 300/4? DcMaN Subwoofers 1 17th September 2010 10:28 AM
jl audio 1000.1 amp prblem ampjunkielikeme Car Audio 24 11th April 2009 11:21 AM


New To Site? Need Help?

All times are GMT. The time now is 03:53 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2