Orion xtreme 3752 help - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th December 2011, 05:19 AM   #1
diyAudio Member
 
Join Date: Sep 2011
Location: Earth
Default Orion xtreme 3752 help

Hello, I am new to repairing amplifiers however I have been able to fix two amps with the help from reading on this board. My problem is that I have an Orion XTREME 3752 that is blowing fuses as soon as it turns on. I found 2 bad transistors 2N6491 which were replaced however the amp still blew the fuses. I then removed the new 2N6491's and powered the amp on. The fuses didn't blow like when i first removed the bad transistors. This time however I started smelling something so i turned off the power and found 2 330 ohm resistors that were burning. After I replace these resistors what else can I check? Also when i was soldering the new 2N6491's a ring fell out of the soldering point. Could this be the issue? Thanks in advance
Attached Images
File Type: jpg 1z5rs02.jpg (336.5 KB, 31 views)
File Type: jpg 11vnvo8.jpg (127.1 KB, 27 views)
  Reply With Quote
Old 29th December 2011, 07:09 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It looks like the layout of the drive sections is identical for both channels. Find the corresponding parts in the other channel.

If the solder pad lifted but there was no trace connected to it, it's probably not a problem. Solder from the other side. If there is no trace on either side, it could be a problem. Some of the Orion amps used 3 layer boards and the traces were buried between layers of fiberglass.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xtreme 800 acebaker Car Audio 11 27th May 2011 12:06 AM
Orion #5 Clipped Car Audio 1 21st November 2008 04:34 AM
Orion NT 200 vs Orion 2150 SX Clipped Car Audio 3 12th June 2007 01:55 PM
Xtreme Noob - Summing Channels For Mono 3875 CarlosT Chip Amps 37 30th November 2006 12:36 AM


New To Site? Need Help?

All times are GMT. The time now is 04:13 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2