Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th December 2011, 01:02 PM   #1
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Default Memphis Power Reference PR 1.500

I think this is a Type I Class-D amp like on the DVD.

Ive got this amp which had all IRF9640 outputs blown, plus all blown power supply IRFZ44. i replaced the failed outputs, plus put one IRFZ44 into each bank. The amp powered and played, but the replacement IRFZ44 got hot within about 20 seconds. I installed all 8xIRFZ44 and the amp started drawing excessive current. I noticed at this point the drive signal no good to the PS fets. With the drivers removed, the TL494 is showing a good signal to the drivers.

Q5, Q10, Q6, and Q9 are all suspect. A733 and C945 were used in these locations. Can I use BD139/BD140? Also, I cant remember the installation orientation: Q6/Q9 center pad is referencing 0ohms to ground, while Q5/Q10 center pad is measuring 0ohms to B+.

Last edited by Dr Zeus; 27th December 2011 at 01:04 PM.
  Reply With Quote
Old 27th December 2011, 01:16 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
0 ohms to ground on the collector is the PNP transistor.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Have a second Soundstream Reference 500 not working that has internal differences dapert Car Audio 13 24th February 2012 06:18 AM
Need help identifying resistors on Soundstream Reference 500 dapert Car Audio 30 14th February 2012 10:56 AM
memphis pr 500.1 timwebb Car Audio 10 14th February 2011 03:28 AM
Memphis Mojo 2000W amp blown power supply m4ick Car Audio 18 5th February 2010 03:18 PM
Rockford Power 500.2 Amp Troubleshooting power supply. kds9591 Car Audio 6 3rd September 2008 03:09 AM


New To Site? Need Help?

All times are GMT. The time now is 07:23 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2