Rockford FOsgate BD1000 - Page 3 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th December 2011, 09:56 AM   #21
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
A broken connection on the gate leg/pad could cause something like this. Were all of the pads and traces for the gate legs and the gate resistors in good condition?
  Reply With Quote
Old 31st December 2011, 07:08 AM   #22
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
There are a few pads that look a little rough where conected to the gate trace.

Perhaps when I tightened down the mesha board it pulled one of the pads away from a trace and caused the failure.

I am recieving a large shipment of IRF3205's today, I will replace them and be sure to bleed the solder onto the trace a little on all of the gate traces.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 31st December 2011, 09:24 PM   #23
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Tinned power supply fets, checked for leakage all of them good.

Soldered them to the mesha board and checked for resistance betwwen tabs and mesha all read OL

Checked resistance from gate leg of each power supply fet to the other side of the gate resistor and each read 47 ohms or very close to.

Replaced the SG3526 with a new one.

Powered up amp and NOTHING!!!

I have 13.89 volts on pin 14 and 17 from D14.

I have almost no voltage on pin 13 or 16. I dont understand the IC is brand new. I guess it could be bad.

Is there anything else I can test before removing and replacing the IC again???
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 31st December 2011, 09:46 PM   #24
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Where did you get the IC?

Before replacing the IC, post the DC voltage on all of the pins.
  Reply With Quote
Old 1st January 2012, 12:58 AM   #25
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I got the IC's from a seller on ebay who I use on a regular basis for buying fets from. I always have gotten quality parts with matching date codes and have never had any issues. This is the first time I have ordered IC's from them though.

Pin 1: 4.93
Pin 2: 0.004
Pin 3: 4.21
Pin 4: 4.62
Pin 5: 4.94
Pin 6: 0.001
Pin 7: 0.001
Pin 8: 4.51
Pin 9: 3.664
Pin10: 4.25
Pin11: 0.001
Pin12: 4.19
Pin13: 0.009
Pin14: 13.21
Pin15: 0.001
Pin16: 0.008
Pin17: 13.21
Pin18: 4.93

Low voltages on 13 and 16 have me thinking the IC is defective but it is new. I double checked my solder joints and they look good but.......I dont know whats going on. I just want to be 100% the IC is defective before removing it again. The old one was working fine I just thought a new one would be more reliable.

Thoughts?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 1st January 2012, 01:23 AM   #26
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Try replacing the 0 ohm jumper R34 with a 1k resistor.
  Reply With Quote
Old 1st January 2012, 10:22 PM   #27
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I replaced R34 with a 1k resistor and the amp powers up fine and idles fine.

What is the purpose of this resistor kinda like a fuse?

I am going to bolt it in the heat sink now and see if it trys to short out again.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 2nd January 2012, 01:09 AM   #28
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I've never found the brand of ICs that Rockford used and I've never found an IC that would work without the mod. The problem is between the IC that syncs the two oscillators and the 3526. I didn't investigate any further. I made sure that the sync was good with the 1k resistor and that was good enough for me.
  Reply With Quote
Old 2nd January 2012, 01:35 AM   #29
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Thats interesting and good to know. The reason the old one worked is because I took it off of a parts board and it was an original Rockford part.

I have not had a chance to put the board in the sink yet but I will later tonight and re-post my results.

Thanks for your help so far Perry and Happy New Year.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 2nd January 2012, 02:56 AM   #30
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I bolted the board down in the sink. Before powering up the amp I tested for resistance between the tabs of the fets and the heat sink. Alot of them show resistance.

Is this normal when bolted into the sink? I want your opinion before powering up the amp. I didnt get any resistance from the tabs to the bottom of the MESHA board while the board was out of the sink and it powers fine out of the sink.

I dont want to fry another 8 power supply fets.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate BD1000.1 jandar Car Audio 11 21st June 2013 11:43 PM
Rockford Fosgate bd1000 Problem comecoquito Car Audio 6 14th December 2011 09:58 PM
Rockford Fosgate BD1000 seankane Car Audio 133 1st April 2011 06:57 AM
rockford fosgate BD1000 mike49504 Car Audio 73 10th February 2011 06:05 PM
Rockford Fosgate BD1000 mike49504 Car Audio 1 9th January 2011 11:37 AM


New To Site? Need Help?

All times are GMT. The time now is 07:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2