Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd December 2011, 05:15 AM   #1
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Default Rockford Fosgate BD500

Hello everyone.

I have a Rockford BD500 I am repairing.

Whats been done so far:

All output fets have been changed and gate reistors.

U6 MIC4420CT driver


The amp is squeeling from the torroid and has 36.50 VDC on the positive output terminal.

I am not getting a square waveform on pin 6 of U8.

The drive circuit in the power supply has a nice square waveform.

One half of the amp has square waveform on the gate resistors but is a little hazy, the other side does not.

Why the 36.50 VDC and the squeeling?

Perhaps a bad op-amp TL072C?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 22nd December 2011, 05:25 AM   #2
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Now neither side of the output gate circuit is a square waveform and the output are getting very warm on one side.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 22nd December 2011, 05:39 AM   #3
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I disconnected R31 and the voltage on the output terminal dropped to 7.50 VDC and the squeeling stopped and the output no longer get warm.

Any thoughts?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 22nd December 2011, 10:11 AM   #4
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I found U17 to be defective. I didnt have any new ones in stock so I replaced it with a used one for testing purposes.

I installed the used U17 and re connected R31.

The amp idles fine now and the DC is gone from the positive output terminal.

The torroid still whines a little but not bad.

I have no sound at low volume but when I turn the volume to half the sound is intermittant cutting in and out very distorted.

I dont have a square waveform on pin 6 of U5 and U8, correct me if I am wrong but pin 3 on U5 and U8 according to the schematic are carriers and should be a saw tooth waveform. I dont have that either.

Should there be DC on pins 2,3, and 6 of U5 and U8?

Not sure where to go next.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 22nd December 2011, 12:09 PM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There could be DC because the amp still has at least one more problem. If you don't have ~0v on all of the pins of U11 and you have the proper supply voltages, replace U11.
  Reply With Quote
Old 22nd December 2011, 06:56 PM   #6
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Hey Perry I was debating U11 last night but didnt want to change a part that I didnt know was bad or not. I was not sure what the voltages were suppose to be.

I changed out U11 and the amp works great, thanks again.

Merry CHristmas
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford fosgate 4.6 X mike49504 Car Audio 14 28th May 2011 03:35 PM
Rockford Fosgate BD500 seankane Car Audio 2 14th May 2011 10:31 PM
Rockford Fosgate R286?? Anyone? Tim0123 Car Audio 4 4th May 2011 04:49 PM
Rockford Fosgate dtisme Car Audio 1 5th October 2010 11:39 PM
Rockford Fosgate BD500 mike49504 Car Audio 9 18th July 2010 07:43 AM


New To Site? Need Help?

All times are GMT. The time now is 05:43 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2