Blown Diablo Prototype Repair DIY help please - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th December 2011, 11:42 PM   #1
diyAudio Member
 
Join Date: Dec 2011
Location: Saginaw MI
Default Blown Diablo Prototype Repair DIY help please

Hey guys i was recommended to this fourm by a guy on caco, Ok here is what happened.

I was stupid and hooked my diablo 2500 prototype directly to a battery charger, it went over 16v and blew a cap, I dont know what else it did. I made a video if someone could help me out! thanks alot

Help me Fix my Diablo 2500 prototype - YouTube

More on the blown amp - YouTube

More on amp 2 - YouTube

These are all videos i made today, some guys on caco were trying to help me, they think i might have a shorted transistor.

here is a link the the thread on caco- Can someone help me fix my amp? - Car Audio Classifieds
  Reply With Quote
Old 14th December 2011, 11:54 PM   #2
diyAudio Member
 
Join Date: Dec 2011
Location: Saginaw MI
here are some pics of my board where the other fourm guys said the problem could be

Click the image to open in full size.

Click the image to open in full size.
  Reply With Quote
Old 15th December 2011, 12:04 AM   #3
diyAudio Member
 
Join Date: Dec 2011
Location: Saginaw MI
What happened is it blew a cap, i replaced the cap and now the amp does nothing but click when it gets power
  Reply With Quote
Old 15th December 2011, 12:08 AM   #4
diyAudio Member
 
Join Date: Dec 2011
Location: Saginaw MI
voltage on the TL494 IC


Voltages on Pins 1-16

INPUT VOLTAGE 13.5v

1- 0
2- 3.16
3- 0
4- .05
5- 1.46
6- 3.61
7- 0
8- .68
9- .09 to 1
10- Same as 9
11- .68
12- 13.73
13- 4.99
14- 4.99
15- 4.82 to 4.83
16- 0



These are the voltages for the rectangle thing right by the 494


I'm measuring them from clostest to the 494 to far

Pin 1- 12.53
Pin 2 - 0
3- 4.99
4- .01
5- 0
6- 3.04
7- 11.72
8- 0
  Reply With Quote
Old 15th December 2011, 12:10 AM   #5
diyAudio Member
 
Join Date: Dec 2011
Location: Saginaw MI
I didn't have the batt charger on the battery so those voltages were from straight off the battery for the rectangle part, (btw it has no part # it was scratched off not by me tho)
  Reply With Quote
Old 15th December 2011, 01:53 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You need to determine why pins 8 and 11 0f the 494 don't have 12v (approximately) on them.

As a side note, my anti-virus alerted me to a potential problem (faceboax.a) on that site (car audio classifieds) and two other sites (that scan domains for threats) list it as suspicious. If you're a regular visitor of that site, you may want to ask the moderators to see if the site has been hacked.
  Reply With Quote
Old 15th December 2011, 11:19 AM   #7
diyAudio Member
 
Join Date: Dec 2011
Location: Saginaw MI
Where should i start checking?
  Reply With Quote
Old 15th December 2011, 12:24 PM   #8
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Follow the traces from pin 11 or 8 on the PC board back to the parts. It should be a part that ties to + voltage.

Read the basic amp repair from Perry's sig line.

Sent from my DROID using Tapatalk
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 15th December 2011, 08:05 PM   #9
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Since this company is belly up, can you get the schematic from the fellow on CACO?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help w/ Diablo 5000 amp Tom7227 Class D 0 27th December 2009 08:15 PM
PCB Prototype for DIY suds Vendor's Bazaar 1 13th September 2009 06:11 PM
Blown Audiobahn AX600 AMP: Repair? Dominick22 Car Audio 13 30th May 2006 06:41 PM
blown crunch amp repair? sctt78 Car Audio 2 6th July 2004 01:06 PM
Boss REV3000D blown amp. Repair Suggestions? KyferEz Car Audio 4 5th May 2004 11:30 PM


New To Site? Need Help?

All times are GMT. The time now is 03:05 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2