PPI A600 gate resistor value - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th November 2011, 07:40 PM   #1
diyAudio Member
 
Join Date: Jun 2007
Default PPI A600 gate resistor value

I'm replacing all 8 FET's in the power supply section of an A600. I'm pretty new to this but came across some threads about upgrading them to stronger parts. IRFZ48V's seem to be the strongest parts I could find so that's what I ordered. Additional reading revealed information about different gate resistor values for different FET's.

Can anyone tell me what values to use for the gate resistors when using IRFZ48V transistors?
  Reply With Quote
Old 4th November 2011, 08:32 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The Z48s should be OK with anything between 47 and 75 ohms. If you have to order or buy the resistors, I'd suggest 68 ohms unless a lower value is already installed.
  Reply With Quote
Old 7th November 2011, 12:21 PM   #3
diyAudio Member
 
Join Date: Jun 2007
I just measured the existing ones and they are 47's, so I'll leave 'em. I bought the amp "non-working" and found 3 z44n's that looked about like they'd exploded since there were parts of the actual silicon missing revealing whatever the core is made of. All the caps, the board, and all else looks great. I'm crossing my fingers this will come alive once I get the z48v's in.
  Reply With Quote
Old 7th November 2011, 05:21 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The outside of the transistor is some sort of epoxy/resin/plastic. The parts inside that look like broken glass is the silicon that makes up the transistor. The tiny rectangle in the center of the metal tab in the following image is the transistor (not intact due to the case being forced open).
http://www.bcae1.com/repairbasicsfor...R_IRFZ44Nb.jpg

This one shows what a silicon die looks like when intact. This is only one example. The various manufacturers use different designs, generally trying to minimize the amount of silicon to meet the specifications of a device.
http://www.bcae1.com/repairbasicsfor...hi_2SK135b.jpg
  Reply With Quote
Old 9th November 2011, 03:23 PM   #5
diyAudio Member
 
Join Date: Jun 2007
Well, I soldered in the z48's and went to test it. It popped the 50 amp fuse in my 8ga cable as soon as I plugged in just the power connector. I took the cover off to check for damage and the FET's all visually look fine but 7 of the 8 are showing shorts between all 3 legs and also between the legs and the metal tab on the bottom.

I didn't measure them before installing but wish I would have. Is there anything else I should be taking a look at before trying another batch of FETs?
  Reply With Quote
Old 9th November 2011, 05:10 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Look for solder bridges between the legs/solder pads.

You never apply direct power through a large fuse before you confirm that the amp is working properly. Read and re-read everything in the yellow box on the basic repair page (link in sig line below).
  Reply With Quote
Old 22nd November 2011, 08:27 AM   #7
diyAudio Member
 
Join Date: Jun 2007
Still working on this one. I'm curious about the 2 legged rectifier diodes. There are two of them on each side. On one side they read a very high resistance value and on the other side - very low as in .3~.4 ohms. Is this an indication that they are bad? Or is there something else in a parallel fashion to them that is making it seem so? There is no visual damage to them, but I guess they could be damaged internally.
  Reply With Quote
Old 22nd November 2011, 10:49 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Remove them from the board and recheck them.
  Reply With Quote
Old 22nd November 2011, 12:40 PM   #9
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Pardon me, but what kind of power supply fets were originally in this amp? IRFZ44/46?

It wont make a substantial different, but since this is your amp and you are wanting to upgrade you might want to look at IRF3205 as they are stonger still than the IRFZ48. I'm not sure if the drive circuit will need modification though; or if the upgrade will actually make anything better.
  Reply With Quote
Old 29th November 2011, 01:48 PM   #10
diyAudio Member
 
Join Date: Jun 2007
I finally got a chance to remove all 4 of the two legged rectifiers. Only one of them appears to be shorted but on the board it was appearing that both of them on that side were shorted. I'm guessing they must be paralell pairs. I replaced all 4 of them anyway with brand new parts. I haven't tried re-powering it yet, but I do have a pack of 10 amp atc fuses ready to test with.

I've measured the output transistors and haven't seen anything shorted out and visually everything else on the board looks good. I did measure Q17 and Q25 which are small barrel shaped transistors near the center of the board on the power supply end and found a couple of legs on each to read .2 ohms. Can anyone tell me the function of these two small transistors or have a schematic to tell how they tie in?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ppi a600 wondernutz Car Audio 12 30th November 2011 01:25 PM
Ppi a600 mike49504 Car Audio 3 21st March 2010 01:44 AM
PPI A600 problems Riveted1 Car Audio 5 29th January 2009 08:35 PM
Ppi A600 npenson Car Audio 4 27th August 2008 10:36 PM
Upgrading a PPI A600.2 MazdaBoi Car Audio 6 12th March 2008 07:47 PM


New To Site? Need Help?

All times are GMT. The time now is 01:19 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2