Hifonics Brutus 1206D - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st October 2011, 04:00 AM   #1
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Default Hifonics Brutus 1206D

Ive got this amp on the bench which warants repair. One rail cap vented so I replaced them all. I had the amp working briefly after that, but a few minutes into testing and now all the amp outputs is loud buzzes which are vaugly in relation to the frequency generator's input signal.

I found 0.050vDC on RCA shields so I proceeded to remove Q11 on the driver board. I found Q11 bad, but no other components. I replaced Q11, a 1D transistor: MMBTA42. There is no longer DC on RCA shields but the amp still produces massive distorion/buzz.

One more thing, if I increase te input signal strong enough, speaker outputs start to produce slight DC. Once ~2v hits, the amp goes into protection.
  Reply With Quote
Old 31st October 2011, 07:18 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Try replacing Q7 as well. It may be open.
  Reply With Quote
Old 31st October 2011, 12:51 PM   #3
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
Q7 is fine. I fixed this amp; found I had not made good solder connections on Q11 when I replaced it last night. This amp is up and working perfectly now.
Thanks!
  Reply With Quote
Old 31st October 2011, 01:04 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
In the future, replace Q7 and 11 together. They both run too hot and both tend to fail. If you haven't replaced Q7, you'll probably see that it's turned brown from overheating.
  Reply With Quote
Old 31st October 2011, 01:05 PM   #5
Dr Zeus is offline Dr Zeus  United States
diyAudio Member
 
Dr Zeus's Avatar
 
Join Date: Oct 2010
OK I'll replace Q7
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics Brutus BX1605D mike49504 Car Audio 3 25th July 2011 05:12 AM
Hifonics Brutus BX2200d Rabbi Car Audio 29 27th January 2011 02:10 AM
Brutus 1206D started squeaking (like a bird) today rurockn Car Audio 11 14th September 2010 03:54 PM
Hifonics Brutus lee1976 Car Audio 3 20th July 2010 11:19 AM
Problems with hifonics brutus 1206d amp bull28 Car Audio 16 3rd June 2010 02:26 PM


New To Site? Need Help?

All times are GMT. The time now is 10:08 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2