Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th October 2011, 03:35 AM   #1
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
Default quick question

my friend has a hifonics 2000 brutus amp and he was hooking something up when he touched the wires to the rca's together . he said it made a loud pop a few times.and it stopped playing. i checked the opamps all are dead but one that have pos and neg voltage.should i replace them all?
  Reply With Quote
Old 13th October 2011, 03:51 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What wire touched the RCA?

RCA jack on the amp or RCA cable from the head unit?

Did it pop through the speakers or did something pop inside the amp?

What do you mean when you say the op-amps are dead?
  Reply With Quote
Old 13th October 2011, 04:05 AM   #3
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
he cut the wires to the rca's and they touch while the amp was on.
he said the speakers made a loud pop a few times then stopped playing.
none of the opamps are functioning. only one is working.

heres a quick pic i took i will take it out the case tomorrow.
Attached Images
File Type: jpg IMAG0126 (2).jpg (981.8 KB, 36 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick quick question ! guitvinny Pass Labs 6 7th February 2007 04:20 PM
one quick question... MyNameIsJake Car Audio 0 24th December 2005 05:51 AM
quick question ... really m0nty Solid State 7 9th September 2005 02:43 PM
Quick question.. bafke Multi-Way 5 11th November 2003 02:47 PM


New To Site? Need Help?

All times are GMT. The time now is 09:25 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2