U.S.AMP 2000X - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th October 2011, 11:05 PM   #1
diyAudio Member
 
Join Date: Oct 2009
Default U.S.AMP 2000X

This unit goes to protection (sat) between 3 to 6 hour after
power on. no leakage or shortage transistors, any suggestion?
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 11th October 2011, 11:40 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Is it going into thermal protection?
  Reply With Quote
Old 12th October 2011, 03:54 AM   #3
diyAudio Member
 
Join Date: Oct 2009
don`t think so, because I shorted the thermistor
and same thin.
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 12th October 2011, 04:09 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
When it shuts down, does the power supply shut down or do you simply lose audio?
  Reply With Quote
Old 15th October 2011, 03:57 PM   #5
diyAudio Member
 
Join Date: Oct 2009
I let this amp play for over 15 hour at
50 % Of its volume and no problem,
but when Go more than 75 % volume
it goes into Aux mode.
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 15th October 2011, 05:17 PM   #6
diyAudio Member
 
Join Date: Aug 2011
What's your battery like?
  Reply With Quote
Old 15th October 2011, 11:52 PM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What is aux mode?
  Reply With Quote
Old 16th October 2011, 10:47 AM   #8
diyAudio Member
 
Join Date: Oct 2009
Sorry, I ment sat mode.
About the battery, I should
I look for?
__________________
fluke 50 mhz scope,35 amp power supply,0.5-12v adj power supply, fluke 179,hot air desolder gun, merit multyfuntion signal tracer/generator.
  Reply With Quote
Old 18th October 2011, 12:13 PM   #9
diyAudio Member
 
Join Date: Aug 2011
Look at the voltage your battery is displaying when the amp cuts out-your power supply may be sagging and causing the amp to shut down.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USAmps 2000x Dr Zeus Car Audio 38 29th July 2013 01:15 PM
Modify & build out (2) Western Electric 300B / 2A3 Hammond monoblock amps & UTC LS-5 quality sound Tubes / Valves 0 9th May 2009 04:59 PM
Krell KSA 80 bias & dc offset check & adjust procedure Clouseaupte Solid State 3 9th August 2007 10:39 AM
DIY-AMP <ZAS> Low THD & IM high bandwith murphy Solid State 18 30th December 2005 11:28 AM


New To Site? Need Help?

All times are GMT. The time now is 02:59 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2