Crossfire CFA602 trouble - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th October 2011, 03:28 PM   #1
diyAudio Member
 
Join Date: Jun 2002
Location: non
Default Crossfire CFA602 trouble

This one is odd. it works fine, no shorted outputs, but theres almost no power behind its output. its real weak, and it isnt loud, almost distorts when turning up.

Rail voltage is +/-27v. And one of the toroids gets red hot real fast.

any ideas?
  Reply With Quote
Old 11th October 2011, 03:52 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
How much current is it drawing?

Do you have a scope?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crossfire bmf1000d jordan_ciaramit Car Audio 1 8th September 2011 02:23 PM
Crossfire XP2400D Dr Zeus Car Audio 36 28th January 2011 01:27 AM
Crossfire CFA602 mike49504 Car Audio 18 12th November 2010 07:01 AM
Crossfire CFA602 - Power light goes bright, then dims (reoccurring justlikemusic Car Audio 4 16th June 2010 12:35 AM
help repairing crossfire CFA602 amp grjr Car Audio 14 25th November 2007 04:31 AM


New To Site? Need Help?

All times are GMT. The time now is 02:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2