Orion MBR not charging - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th September 2011, 01:47 PM   #1
manina is offline manina  Germany
diyAudio Member
 
Join Date: Mar 2008
Location: Where the work is
Default Orion MBR not charging

My Orion MBR is no longer charging the secondary battery. When it's powered, only the red light turno on (indicating it's ON) but no green light (indicating it's charging).

I tested it with a fixed voltage supply (13.6V) and does not work. At a visula inspection, nothing is burn.

What should I check?

Thanks
  Reply With Quote
Old 28th September 2011, 02:12 PM   #2
diyAudio Member
 
Join Date: Apr 2011
Location: Anchorage AK
pics? i take it's not solid state?
  Reply With Quote
Old 28th September 2011, 03:14 PM   #3
manina is offline manina  Germany
diyAudio Member
 
Join Date: Mar 2008
Location: Where the work is
Here it's the MBR. I removed the 2n6488 on the bottom right hoping they are the problem.

Before removing them, I measured the two TL494 voltage - supply was 13,54V
Bottom right TL494
Pin 1 - 0,006V
Pin 2 - 0,07V
Pin 3 - 0,07V
Pin 4 - 0,02V
Pin 5 - 1,52V
Pin 6 - 3,36
Pin 7 - 0,006V
Pin 8 - 4,08V
Pin 9 - 1,51V
Pin 10 - 1,19V
Pin 11 - 4,05V
Pin 12 - 12,84V
Pin 13 - 5,08
Pin 14 - 5,08
Pin 15 - 0,07V
Pin 16 - 0,006V

Upper right TL494
Pin 1 - 0,006V
Pin 2 - 4,79V
Pin 3 - 4,79V
Pin 4 - 0,01V
Pin 5 - 1,55V
Pin 6 - 3,51V
Pin 7 - 0,006V
Pin 8 - 30,22V
Pin 9 - 0,34V
Pin 10 - 0,34V
Pin 11 - 30,24V
Pin 12 - 30,25V
Pin 13 - 0,06
Pin 14 - 5,04
Pin 15 - 4,79V
Pin 16 - 9,14V
Attached Images
File Type: jpg MBR70.jpg (587.5 KB, 201 views)
  Reply With Quote
Old 28th September 2011, 03:21 PM   #4
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
Here is a link to its schematic . its a mosfet based device.

http://www.compendiumarcana.com/foru...OrionMBR70.pdf
  Reply With Quote
Old 28th September 2011, 03:29 PM   #5
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
Better yet here it is attached
Attached Files
File Type: pdf OrionMBR70.pdf (37.6 KB, 73 views)
  Reply With Quote
Old 28th September 2011, 08:45 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It appears that it needs to have a battery connected to its output to have any output.

If you connect B+ to the input and short the collector and emitter of Q6, that should force it to produce output.
  Reply With Quote
Old 5th October 2011, 08:20 PM   #7
manina is offline manina  Germany
diyAudio Member
 
Join Date: Mar 2008
Location: Where the work is
Thanks for the schematics and the hints. As soon as I get the 2n6488 to replace the ones taken out, I'll do some more tests.
  Reply With Quote
Old 7th November 2011, 08:59 AM   #8
manina is offline manina  Germany
diyAudio Member
 
Join Date: Mar 2008
Location: Where the work is
I had finally time to re-assemble the MBR and test it with a battery. It does not work

The green led turn on but there is no output voltage.

The source is a fixed voltage supply running at 13,7V so definitely enough to turn it on.

I can only think the second TL494 (right side of the PDF) has problems as the first one is properly driving the 30V (actually, 30,01V)

I also checked the resistors (all) and all are as per the schematic - nothing burned.

Any suggestion?
  Reply With Quote
Old 7th November 2011, 05:27 PM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post the DC voltage on all pine of Q5 and Q6 with the MBR connected as it would be normally (battery on input and on output).
  Reply With Quote
Old 10th November 2011, 02:30 PM   #10
manina is offline manina  Germany
diyAudio Member
 
Join Date: Mar 2008
Location: Where the work is
Quote:
Originally Posted by Perry Babin View Post
Post the DC voltage on all pine of Q5 and Q6 with the MBR connected as it would be normally (battery on input and on output).
Q5 (MPSA56)
1 13,29
2 12,64
3 0,7 3

Q6 (MPSA06)
1 0,04
2 0,73
3 0,05
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
charging capacitor joeyd71 Car Audio 4 4th April 2009 08:24 AM
Orion NT 200 vs Orion 2150 SX Clipped Car Audio 3 12th June 2007 01:55 PM
Self Charging Capacitors?! Rarkov Parts 4 6th August 2003 07:06 AM
MBR series Piersma Solid State 0 9th March 2003 07:08 PM
Pick-up of charging spikes Jamie F Solid State 19 11th January 2002 12:52 PM


New To Site? Need Help?

All times are GMT. The time now is 07:14 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2