kenwood kac ps811d need help fixing - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th September 2011, 05:04 PM   #1
mrus24 is offline mrus24  United States
diyAudio Member
 
Join Date: Sep 2011
Default kenwood kac ps811d need help fixing

right guys i was wandering if anyone could help me with this.the problem is there is no sound coming from the amp and if i touch the speaker wires together it does not go into protect mode ie.light starts flashing.i think i know what caused the problem .the wires came from out of my sub and the mrs as put them back into one connector causing a constant short.this was left for i guess a couple of months before i found out.any help please
  Reply With Quote
Old 15th September 2011, 06:14 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you want to try to repair it yourself and are new to amp repair, you need to read the basic amp repair page in its entirety (link in sig line below).

Have you opened it up to see if there any visible signs of damage?
  Reply With Quote
Old 15th September 2011, 06:48 PM   #3
mrus24 is offline mrus24  United States
diyAudio Member
 
Join Date: Sep 2011
ok will check that thanks i have opened it up but cant see any blow marks or bulging caps thanks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood KAC-Q74 mike49504 Car Audio 3 21st April 2011 08:38 PM
Kenwood KAC 829 mike49504 Car Audio 1 21st April 2011 06:45 PM
Kenwood KAC-x30it fragmental Car Audio 2 15th March 2011 06:33 PM
Kenwood KAC-X810D mike49504 Car Audio 2 20th February 2010 01:49 PM
Kenwood KAC-X301T and KAC-X201T:Do they share the same board? spooney Car Audio 1 25th October 2007 01:08 AM


New To Site? Need Help?

All times are GMT. The time now is 04:10 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2