Help with Memphis 1000D's - Page 7 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th September 2011, 04:08 AM   #61
diyAudio Member
 
Join Date: Sep 2011
Location: Buffalo N.Y.
Quote:
Originally Posted by Perry Babin View Post
Didn't you state that one of the two 640s had failed and one of the 9640s had failed?
Yes, the second amp I worked on had one of each blown on the same output side of the amp. The first amp had a 640 blown on one output side, and a 9640 blown on the other output side. Uh oh, I might of just clipped out all of the output transistors in the first amp for nothing.
__________________
Free Project Pat!! Free Project Pat!!
  Reply With Quote
Old 19th September 2011, 04:12 AM   #62
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If one of each parallel group failed, all in the parallel group must be replaced (if you want the amp to be as reliable as possible).
  Reply With Quote
Old 19th September 2011, 04:37 AM   #63
diyAudio Member
 
Join Date: Sep 2011
Location: Buffalo N.Y.
Quote:
Originally Posted by Perry Babin View Post
If one of each parallel group failed, all in the parallel group must be replaced (if you want the amp to be as reliable as possible).
I'm a little confused, are the two separate parallel groups in parallel with eachother or something?? I'm just trying to learn as much as possible. Either way I took them all out so I have to replace them with new ones. Thanks again for your assistance.
__________________
Free Project Pat!! Free Project Pat!!
  Reply With Quote
Old 19th September 2011, 06:02 AM   #64
diyAudio Member
 
Join Date: Sep 2011
Location: Buffalo N.Y.
Quote:
Originally Posted by project pat View Post
I'm a little confused, are the two separate parallel groups in parallel with eachother or something?? I'm just trying to learn as much as possible. Either way I took them all out so I have to replace them with new ones. Thanks again for your assistance.
I was confused because you didnt say wether or not I pulled the others out for nothing. I think from what your saying though I did. You learn as you go I guess.
__________________
Free Project Pat!! Free Project Pat!!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
memphis 1500 timwebb Car Audio 3 8th August 2011 03:20 AM
memphis 1500d timwebb Car Audio 11 21st July 2010 09:33 PM
memphis 1500d timwebb Car Audio 4 1st June 2010 01:23 PM
memphis 1000 mike49504 Car Audio 43 13th January 2010 04:34 PM
Memphis...? hooverjr10 Subwoofers 0 14th December 2007 03:16 AM


New To Site? Need Help?

All times are GMT. The time now is 12:39 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2