Xtant 3150c Issues - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th September 2011, 06:58 AM   #1
Mazar' is offline Mazar'  United States
diyAudio Member
 
Join Date: Apr 2006
Location: Texas
Default Xtant 3150c Issues

I have been trying to solve an issue I have with my Xtant 3150c. The problem is that there is no sound unless i turn the gain up and then there is only distortion. I am not familiar xtant amplifiers so I have only checked a few things. There is roughly 6.5Vdc on the speaker terminals. I have checked all diodes for open circuits and all seem to be fine.

Does anyone here have knowledge of this old Xtant? Any help would be greatly appreciated. I have all the tools needed to test and repair the amp.
  Reply With Quote
Old 8th September 2011, 03:25 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I'm not familiar with the 3150. If no one else can help, post at least one good quality photo of the board.
  Reply With Quote
Old 8th September 2011, 03:39 PM   #3
Mazar' is offline Mazar'  United States
diyAudio Member
 
Join Date: Apr 2006
Location: Texas
I will get some high quality photos tonight after I return from work. Is it common for Older Xtant amps to have hand modifications on the PCB?
  Reply With Quote
Old 8th September 2011, 03:54 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I don't have a lot of experience with them but I don't remember any jumpers or point to point wiring.
  Reply With Quote
Old 27th July 2012, 10:38 PM   #5
MOER is offline MOER  United States
diyAudio Member
 
Join Date: Aug 2003
Location: SIMI VALLEY CA
Default xtant 3150c schematics

Hi all,

Does anybody have a schematic for this Xtant 3150C?

Please if you do I would appreciate if you would email it to me at ZEDAUDIO@AOL.COM
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xtant 6.1 repair lumanauw Car Audio 4 20th March 2011 03:22 AM
XTant 603x Dr Zeus Car Audio 9 6th February 2011 07:55 PM
Xtant X1001 shagone Car Audio 11 15th April 2008 01:28 AM
xtant 3300c nath339 Car Audio 4 30th March 2008 03:50 AM
Xtant 3150c kelwin Car Audio 4 23rd October 2007 10:58 PM


New To Site? Need Help?

All times are GMT. The time now is 01:06 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2