MTX TC6001 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd September 2011, 04:37 PM   #1
diyAudio Member
 
Join Date: May 2011
Default MTX TC6001

HI,Perry.I need your help.Do you have the Amplifier photo? This amplifier has been repaired, but still not fix it, some resistors and transistors are not the original model.
Attached Images
File Type: jpg 201109021161.jpg (574.6 KB, 39 views)
File Type: jpg 201109021163.jpg (485.8 KB, 37 views)
File Type: jpg 201109021162.jpg (350.2 KB, 37 views)
  Reply With Quote
Old 3rd September 2011, 03:31 AM   #2
timwebb is offline timwebb  United States
diyAudio Member
 
Join Date: Jan 2010
Location: memphis tn
whats wrong with it?
  Reply With Quote
Old 3rd September 2011, 03:37 AM   #3
diyAudio Member
 
Join Date: Oct 2010
it looks like all the outputs are missing. if you didn't remove the parts yourself and you don't have a scematic it may be difficult to repair.

but don't let me discourage you, perry is "THE KING" and in my opinion can work miracles.

Last edited by bdgf2004; 3rd September 2011 at 03:40 AM.
  Reply With Quote
Old 3rd September 2011, 03:55 AM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I'm sorry, I don't have any information on that amp.

If the components are aligned perfectly straight with the solder pads, there's a good chance that they're the original parts.

Have you tried installing all of the components to see if there is a problem or to determine what sort of problem it has?
  Reply With Quote
Old 7th September 2011, 02:58 PM   #5
diyAudio Member
 
Join Date: May 2011
Quote:
Originally Posted by ALPINE AJ View Post
HI,Perry.I need your help.Do you have the Amplifier photo? This amplifier has been repaired, but still not fix it, some resistors and transistors are not the original model.
I found the problem
R516=471(470 Ohm)
R520=471(470 Ohm)
R528=221(220 Ohm)
Attached Images
File Type: jpg 201109021161.jpg (427.4 KB, 21 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
orion hcca250r, kicker zr 1000, mmats d800.2, mtx 6500d, mtx 942, rockford punch 45, ernie cosillos Swap Meet 3 12th February 2011 11:14 AM
Mtx ptp251d mbates14 Car Audio 3 7th February 2010 02:54 AM
mtx 300xd help mjrpainless Car Audio 8 4th January 2009 02:22 AM
Help me fix MTX 152 and MTX 500D hakentt Car Audio 94 8th December 2008 06:26 PM
MTX TC6001 repair Kevin_Murray Car Audio 1 13th February 2008 05:52 PM


New To Site? Need Help?

All times are GMT. The time now is 08:39 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2