Just installed new amp and sub, need help. - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd September 2011, 04:24 AM   #1
unreal is offline unreal  United States
diyAudio Member
 
Join Date: Sep 2011
Default Just installed new amp and sub, need help.

Before i ask this i just wanted to say i have no idea about the stereo or subs or anything about. I got a new amp and sub 1000watts insalled free by my friend. He said that i would need to get a cannister installed for my system because it is going to drain my battery, and he also said i cant use my subwoofer to the fullest (he said i can only have one plug plugged in instead of both or my system will mess up and that i have to keep my music low because my wiring is messed up that it could be grounded.) He said that his frend could rewire everything and add a canister for $150. Im sorry if this didnt make sense but is this a legit price? Im not sure on what to do. Thank you
  Reply With Quote
Old 2nd September 2011, 08:00 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The capacitor (canister?) is a waste of money.

Is he saying that you can only have one RCA jack filled on the input RCAs?

How will it mess up?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just installed VAM1202..... martipie Digital Source 9 19th September 2013 06:13 AM
Installed 12" Speaker in Pro Jr---Now What?? exmaxima Tubes / Valves 2 19th January 2009 10:23 PM
new FETs installed, no power. profuse007 Car Audio 29 22nd February 2006 12:22 AM
Just installed. What is wrong with my sound? npcout Car Audio 6 24th January 2006 01:45 AM


New To Site? Need Help?

All times are GMT. The time now is 03:08 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2