punch 600a4 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th August 2011, 05:38 PM   #1
diyAudio Member
 
Join Date: Jun 2010
Default punch 600a4

This amp came in with two burn ch.All output transistors and some emmiter resistor was bad in these two ch.I unsolder all outputs and emmiters on these two ch.This amp still will not power up,i think it is going into protect.I pull the center legs of the rectifers off the board and got 41 volts on them but the power light is still off.If the drivers on the two burn ch are bad will it cause that?Any idea what is causing this amp not to power up?
Attached Images
File Type: jpg punch01.JPG (510.3 KB, 86 views)
File Type: jpg punch02.JPG (505.4 KB, 82 views)
File Type: jpg punch03.JPG (365.7 KB, 71 views)
  Reply With Quote
Old 28th August 2011, 05:58 PM   #2
fcruz is offline fcruz  Brazil
diyAudio Member
 
Join Date: Apr 2011
What is your email address to send you to the scheme
  Reply With Quote
Old 28th August 2011, 06:05 PM   #3
diyAudio Member
 
Join Date: Jun 2010
ranks33@hotmail.com



thanks
  Reply With Quote
Old 28th August 2011, 10:19 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Most Rockford amps drive the power LED from the regulated 15v supply. The 15v supply typically gets its power from the rectifiers. If the rectifiers are out of the circuit, the LED can't light up.

When you say it won't power up, does it drag the voltage from the power supply down or does it simply refuse to produce any rail voltage?
  Reply With Quote
Old 28th August 2011, 11:25 PM   #5
diyAudio Member
 
Join Date: Jun 2010
with the rectifier in ciruit it has rail voltage for about 3 seconds.During that 3 seconds the light is on.I have a light blup limmiter on the power line it does not light so it is not drawing to much current.
  Reply With Quote
Old 28th August 2011, 11:35 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post the DC voltage on all pins of the LM339 after rail voltage is lost.

Pin 1:
Pin 2:
Pin 3:
Pin 4:
Pin 5:
Pin 6:
Pin 7:
Pin 8:
Pin 9:
Pin 10:
Pin 11:
Pin 12:
Pin 13:
Pin 14:
  Reply With Quote
Old 30th August 2011, 10:35 PM   #7
diyAudio Member
 
Join Date: Jun 2010
I resolder the middle leg of the rectifiers back on the board and now the amp stays power on.I think somthing is about to fail.It has both +&- rail voltage.


LM339

Pin 1: 2.l
Pin 2: 4.7
Pin 3: 13.1
Pin 4: 0
Pin 5: 2.4
Pin 6: 4.8
Pin 7: 4.7
Pin 8: 3.2
Pin 9: 4.8
Pin 10: 4.8
Pin 11: 5.1 plusin to 6.8
Pin 12: 0
Pin 13: 4.3
Pin 14: 4.3
  Reply With Quote
Old 31st August 2011, 12:03 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Recheck 1, 6 and 7. They're critical. Also, if you have a scope, look at the voltage on those pins to confirm that they're straight DC and not pulsing DC.
  Reply With Quote
Old 31st August 2011, 11:26 PM   #9
diyAudio Member
 
Join Date: Jun 2010
pin1: plusing from 0 to 12 volts
pin6:4.88
pin7: plusing from 4 to 5 volts

This amp is not powering up without a current limmiter.
  Reply With Quote
Old 31st August 2011, 11:42 PM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Try powering the amp up with the B+ terminal limited but the remote terminal connected directly to the 12v power supply.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PUNCH 4060X bdgf2004 Car Audio 21 7th March 2011 04:03 AM
HELP! Fosgate 600A4 Brain Fried Car Audio 9 12th April 2010 01:41 AM
Rockford fostgate 600a4 OneLostSoul Car Audio 13 30th August 2009 12:36 AM
Selling a punch 250a2, old punch 75, and ppi epx 205 on EBAY ppia600 Swap Meet 0 23rd February 2008 02:17 AM
My experience: the cheap punch set VS Greenlee punch vax9000 Tubes / Valves 5 21st July 2006 08:52 PM


New To Site? Need Help?

All times are GMT. The time now is 05:33 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2